Bug 626020 - storage test traceback on device size calculation
Summary: storage test traceback on device size calculation
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 1.2
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: chen yuwen
URL:
Whiteboard:
Keywords:
: 628708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-21 14:07 UTC by Greg Nichols
Modified: 2010-09-21 11:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The storage test no longer returns an error when calculating the device size.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 12:15:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage test patch checking status return before calculation of size (638 bytes, patch)
2010-08-21 14:09 UTC, Greg Nichols
no flags Details | Diff
storage patch on R19 fixing traceback in warning message (560 bytes, patch)
2010-08-23 18:56 UTC, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0702 normal SHIPPED_LIVE v7 bug fix and enhancement update 2010-10-21 07:59:09 UTC

Description Greg Nichols 2010-08-21 14:07:23 UTC
Description of problem:

On some systems, the storage test has a traceback when calculating device size:

Traceback (most recent call last):
  File "./storage.py", line 478, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/v7/lib/v7/test.py", line 261, in do
    return self.run()
  File "./storage.py", line 451, in run
    returnValue = self.testRawIO(storageDevice,testdev,minBs,maxBs)
  File "./storage.py", line 368, in testRawIO
    size = self.devSize(testdev)
  File "./storage.py", line 144, in devSize
    output = int(output) / 2
ValueError: invalid literal for int(): cat: /sys/block/mapper/VolGroup00-LogVol01/size: No such file or directory

This happens on both RHEL6 and when storage is run a RHEL5 guest during the fv_storage test.


Version-Release number of selected component (if applicable):

v7 1.2 R18

Comment 1 Greg Nichols 2010-08-21 14:09:18 UTC
Created attachment 440119 [details]
storage test patch checking status return before calculation of size

Comment 3 Gary Case 2010-08-23 18:47:08 UTC
I just tested with -19 on a fresh install of snap 12 x86_64 and I'm still seeing a similar error:

*** Testing raw I/O performance on sda2
Traceback (most recent call last):
  File "./storage.py", line 480, in <module>
    returnValue = test.do(sys.argv)
  File "/usr/share/v7/lib/v7/test.py", line 261, in do
    return self.run()
  File "./storage.py", line 453, in run
    returnValue = self.testRawIO(storageDevice,testdev,minBs,maxBs)
  File "./storage.py", line 370, in testRawIO
    size = self.devSize(testdev)
  File "./storage.py", line 150, in devSize
    print "Warning: can not get device size from /sys/block/%s/size, defaulting to %u. " % (testDevice, size)
NameError: global name 'testDevice' is not defined
...finished running ./storage.py, exit code=1
</output>

This box has no LVM in the mix. It's root/boot/swap, ext4/ext4/swap

-Gary

Comment 4 Greg Nichols 2010-08-23 18:54:23 UTC
That traceback is introduced by the fix in R19.

Comment 5 Greg Nichols 2010-08-23 18:56:13 UTC
Created attachment 440459 [details]
storage patch on R19 fixing traceback in warning message

Comment 6 Gary Case 2010-08-23 20:22:32 UTC
Applying the last storage patch posted gave me a passing storage result with a re-enabled swap partition after the test. It works!

Comment 8 Greg Nichols 2010-08-31 02:43:56 UTC
*** Bug 628708 has been marked as a duplicate of this bug. ***

Comment 10 chen yuwen 2010-09-13 06:22:59 UTC
reproduced in v7-1.2-18 and verified in v7-1.2-24.

Comment 12 errata-xmlrpc 2010-09-20 12:15:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html

Comment 13 Jaromir Hradilek 2010-09-21 11:30:18 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The storage test no longer returns an error when calculating the device size.


Note You need to log in before you can comment on or make changes to this bug.