Bug 626040 - Networking not activated in freshly-installed system
Networking not activated in freshly-installed system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-21 11:45 EDT by Jan Engelhardt
Modified: 2014-03-16 23:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 14:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Engelhardt 2010-08-21 11:45:16 EDT
Description of problem:
After a fresh installation of a system, eth0 is not set up. /etc/sysconfig/network-scripts/ifcfg-eth0 does contain the information used during anaconda installation, however, /etc/init.d/network seems to be not run on boot.

Version-Release number of selected component (if applicable):
F 13 netinst.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 iarly selbir 2010-08-23 07:51:58 EDT
How you configured network on anaconda(dhcp,static.ipv[4,6]), and what was created on /etc/sysconfig/network-scripts/ifcfg-eth0 after system be completely installed?

Thanks for your report.

(In reply to comment #0)
> Description of problem:
> After a fresh installation of a system, eth0 is not set up.
> /etc/sysconfig/network-scripts/ifcfg-eth0 does contain the information used
> during anaconda installation, however, /etc/init.d/network seems to be not run
> on boot.
> 
> Version-Release number of selected component (if applicable):
> F 13 netinst.
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 2 Bill Nottingham 2010-08-23 11:54:55 EDT
Did you just do the minimal install? If you did (and therefore do not install NetworkManager), you will need to enable the network service.
Comment 3 Jan Engelhardt 2010-08-23 14:05:26 EDT
After giving the installer the network setup info, it just installs something without further questions. NetworkManager does not seem to be among that.
Comment 4 Bill Nottingham 2010-08-23 14:27:18 EDT
Was this a text mode install?
Comment 5 Jan Engelhardt 2010-08-23 14:51:50 EDT
It was indeed.
Comment 6 Bill Nottingham 2010-08-23 14:57:19 EDT
OK. text mode install is a minimal install, so it runs into the above situation.
Comment 7 Jan Engelhardt 2010-08-23 15:11:11 EDT
So what? Why can't Fedora have this fixed what other distributions already have?
Comment 8 Bill Nottingham 2010-08-23 15:40:44 EDT
The installer does not have a mechanism to enable and disable services based on the package set installed. TBH, the simplest solution would be to put NetworkManager in the minimal install.
Comment 9 Jan Engelhardt 2010-08-23 16:22:36 EDT
TBH that leaves me unsatisfied - openSUSE can do this. I think what they do is always have /etc/init.d/network in the runlevel, but let ifup (which is called as part of network) skip ethX if ifcfg-ethX has been marked as being controlled by NetworkManager.

Note You need to log in before you can comment on or make changes to this bug.