Bug 62615 - Trigger scriptlet error when trying to remove apmd package
Trigger scriptlet error when trying to remove apmd package
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: apmd (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
: 63184 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-02 23:04 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 18:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2002-04-02 23:04:36 EST
Failure of "rpm -e apmd" ... I now have an almost-removed package which I can't
completely remove without trickery :o)
Basically there appears to be a packaging error with one or more of the scripts,
possibly the "triggerpostun" shown below ...
(I'll clean it up with --noscripts in a second, but here's a record of events)

[root@staryu root]# rpm -e apmd
error reading information on service apmd: No such file or directory
error: execution of %trigger scriptlet from apmd-3.0.2-7 failed, exit status 1
[root@staryu root]# rpm -q --triggers apmd
triggerpostun script (through /bin/sh) -- apmd <= 3.0final-6
/sbin/chkconfig --add apmd
[root@staryu root]# rpm -e apmd
error reading information on service apmd: No such file or directory
error: execution of %preun scriptlet from apmd-3.0.2-7 failed, exit status 1
[root@staryu root]# rpm -q --qf '%{preun}\n' apmd
if [ $1 = 0 ]; then
    service apmd stop > /dev/null 2>&1
    /sbin/chkconfig --del apmd
fi
[root@staryu root]# rpm -q apmd
apmd-3.0.2-7
[root@staryu root]# rpm -V apmd
missing    /etc/rc.d/init.d/apmd
missing    /etc/sysconfig/apm-scripts/apmscript
missing    /etc/sysconfig/apmd
missing    /usr/bin/apm
missing    /usr/bin/apmsleep
missing    /usr/bin/on_ac_power
missing    /usr/include/apm.h
missing    /usr/lib/libapm.a
missing    /usr/sbin/apmd
missing    /usr/share/doc/apmd-3.0.2
missing    /usr/share/doc/apmd-3.0.2/ANNOUNCE
missing    /usr/share/doc/apmd-3.0.2/ChangeLog
missing    /usr/share/doc/apmd-3.0.2/LSM
missing    /usr/share/doc/apmd-3.0.2/README
missing    /usr/share/doc/apmd-3.0.2/README.transfer
missing    /usr/share/man/man1/apm.1.gz
missing    /usr/share/man/man1/apmsleep.1.gz
missing    /usr/share/man/man1/xapm.1.gz
missing    /usr/share/man/man8/apmd.8.gz
Comment 1 Bill Nottingham 2002-04-10 18:31:13 EDT
*** Bug 63184 has been marked as a duplicate of this bug. ***
Comment 2 Bernhard Rosenkraenzer 2002-04-15 07:37:59 EDT
 Added epoch to trigger in 3.0.2-10

Note You need to log in before you can comment on or make changes to this bug.