Bug 626227 - process scan returns command line for basename
process scan returns command line for basename
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
3.0.0
powerpc Other
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-22 16:43 EDT by Thilo Solbrig
Modified: 2014-06-27 16:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-27 16:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thilo Solbrig 2010-08-22 16:43:37 EDT
Description of problem:
process-scan query of rhq-plugin.xml is defined as "process|basename|match=^oracle.*" Process scan correctly returns "oracle" processes on Linux, which's basenames are ora_pmon_..., ora_smon_... and so on. Same plugin run on AIX 6.1 doesn't recognize any "oracle" processes. Changing process-scan query to "process|basename|match=^ora.*" on AIX 6.1 returns ora_pmon_..., ora_smon_... and so on. "ps -eo comm,args" correctly returns "oracle ora_..." pairs as well on Linux as on AIX. 

Version-Release number of selected component (if applicable):
Agent 3.0.0

How reproducible:
Try process-scan query "process|basename|match=^oracle.*" on AIX 6.1

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Process-scan query "process|basename|match=^oracle.*" recognizes Oracle processes on Linux but not on AIX. Process-scan query "process|basename|match=^ora.*" does, probably due to command line pattern of ora_...

Expected results:
Process-scan query "process|basename|match=^oracle.*" to recognize Oracle processes as well on Linux as on AIX.

Additional info:
Comment 1 Jay Shaughnessy 2014-06-27 16:26:07 EDT
This was never changed. Not sure if the AIX issue went away but closing as out of date.  Community submission welcome for new, better pattern if someone wants to re-open.

Note You need to log in before you can comment on or make changes to this bug.