Bug 626266 - WiFi network stops working at random
WiFi network stops working at random
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-22 21:55 EDT by Horst H. von Brand
Modified: 2011-01-14 10:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 10:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log for kernel-2.6.36-0.30.rc6.git0.fc15.x86_64 (broken) (86.63 KB, text/plain)
2010-10-01 18:20 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2010-08-22 21:55:14 EDT
Description of problem:
The WiFi net goes down at random, ifconfig shows the wlan0 interface up (with IP address and all), but ping to the AP says "host unreachable". Have to rmmod iwlagn and restart the network:

  modprobe iwlagn
  iwconfig wlan0 essid xxxx
  killall dhclient
  dhclient wlan0

(NetworkManager is currently totally hosed).

lspci says:
  08:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Version-Release number of selected component (if applicable):
kernel-2.6.36-0.0.rc0.git1.fc15.x86_64

How reproducible:
Happens at random, seems o take a couple of hours of normal use (update rawhide, look at a some webpages, get email via fetchmail, get updates via git and compile the results for a few programs) on average

Steps to Reproduce:
1. Absolutely no clue, sorry
2.
3.
  
Actual results:
ifconfig wlan0 shows interface up, IP assigned; ping 192.168.1.1 (AP) says "host unreachable". Have to remove and reinsert module, restart networking from scratch.

Expected results:


Additional info:
Comment 1 John W. Linville 2010-08-24 13:13:09 EDT
Could we see the output of dmesg immediately after the failure?
Comment 2 Horst H. von Brand 2010-09-27 18:25:21 EDT
Hasn't happened again. Will remember this.

Thanks!
Comment 3 Horst H. von Brand 2010-10-01 18:20:41 EDT
Created attachment 451137 [details]
Boot log for kernel-2.6.36-0.30.rc6.git0.fc15.x86_64 (broken)

Again broken. I just confirmed kernel-2.6.36-0.30.rc6.git0.bz637647.fc15.x86_64 does work (running that one right now).
Comment 4 Horst H. von Brand 2010-10-01 18:21:25 EDT
Sorry about that, wrong bug :-(
Comment 5 John W. Linville 2011-01-13 14:12:12 EST
Presuming comment 4 cancels comment 3...is this still a problem with currently updated Fedora kernels?
Comment 6 Horst H. von Brand 2011-01-14 08:30:03 EST
This hasn't happened again since around August. Better close.

Thanks!
Comment 7 John W. Linville 2011-01-14 10:10:18 EST
Closing on basis of comment 6...

Note You need to log in before you can comment on or make changes to this bug.