Bug 62632 - up2date falsely reports it cannot install package due to insufficient disk space
up2date falsely reports it cannot install package due to insufficient disk space
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-03 09:40 EST by Daniel G. Link
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 16:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel G. Link 2002-04-03 09:40:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
up2date-2.7.46-7.x.1 reports insufficient space for package installation even 
though there is sufficient space.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. up2date -u (system must need update of php-manual-4.0.6-14, don't know about 
other packages)
2.
3.
	

Actual Results:  [...]
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
installing package php-manual-4.0.6-14 needs 23Mb on the /var filesystem

Expected Results:  It should have installed the package "php-manual-4.0.6-14".

Additional info:

Every single file system on this machine has more than 23 MB of free 
space, /var included:

[root@tempest up2date]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda9               256667    161720     81695  67% /
/dev/hda1                38859      4312     32541  12% /boot
/dev/hda7               521748    399176     96068  81% /home
/dev/hda10            36155784  35963464    192320 100% /share
/dev/hda5              6048320   4680468   1060612  82% /usr
/dev/hda8               256667    150034     93381  62% /var
Comment 1 Adrian Likins 2002-05-08 16:19:19 EDT
This looks more like a rpm issue than an up2date one, since it
appears to be miscalculating the space required.
Comment 2 Jeff Johnson 2002-07-06 15:04:19 EDT
The message indicates that 23MB more space is needed
on the /var file system.

Note You need to log in before you can comment on or make changes to this bug.