Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626328 - X.org: DBE should validate front and back buffers separately.
X.org: DBE should validate front and back buffers separately.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: OtherQA, Triaged, ZStream
Depends On: 596899
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 04:13 EDT by RHEL Product and Program Management
Modified: 2013-01-10 22:13 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The 'miDbePositionWindow' function allocates two pixmaps: a front buffer, and a back buffer. If the buffers are supposed to be initialized, it validates a graphic context (GC) against the front buffer, then uses it to fill and/or copy both the front buffer and the back buffer, without revalidating. If the acceleration architecture needed different GC functions for the two pixmaps, for example if allocation of the front buffer exhausted video memory, then this caused crashes because the GC was not validated for the back buffer pixmap. With this update, the crashes no longer occur and GC validation works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 05:26:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0722 normal SHIPPED_LIVE xorg-x11-server bug fix update 2010-09-29 05:26:17 EDT

  None (edit)
Description RHEL Product and Program Management 2010-08-23 04:13:52 EDT
This bug has been copied from bug #596899 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 4 Adam Jackson 2010-09-01 16:32:18 EDT
2727481 build (RHEL-5.5-Z-candidate, /cvs/dist:rpms/xorg-x11-server/RHEL-5:xorg-x11-server-1_1_1-48_76_el5_5_2) completed successfully
Comment 7 Vladimir Benes 2010-09-21 09:45:44 EDT
setting verified field to nVidia as bug #596899 was verified (and this one is a clone)
Comment 9 errata-xmlrpc 2010-09-29 05:26:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0722.html
Comment 10 Martin Prpič 2010-09-29 05:39:34 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The 'miDbePositionWindow' function allocates two pixmaps: a front buffer, and a back buffer. If the buffers are supposed to be initialized, it validates a graphic context (GC) against the front buffer, then uses it to fill and/or copy both the front buffer and the back buffer, without revalidating. If the acceleration architecture needed different GC functions for the two pixmaps, for example if allocation of the front buffer exhausted video memory, then this caused crashes because the GC was not validated for the back buffer pixmap. With this update, the crashes no longer occur and GC validation works as expected.

Note You need to log in before you can comment on or make changes to this bug.