Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626333 - [WHQL] Win2k8-R2 got BSOD during virtio-serial "sleep stress with IO" and "Common scenario stress with IO" testing
[WHQL] Win2k8-R2 got BSOD during virtio-serial "sleep stress with IO" and "Co...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Linux
urgent Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
: 627577 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 04:32 EDT by Qunfang Zhang
Modified: 2013-01-09 18:03 EST (History)
10 users (show)

See Also:
Fixed In Version: virtio-win-1.1.16-0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:01:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
win2k8-r2-virtio-serial-BSOD (21.68 KB, image/png)
2010-08-23 04:32 EDT, Qunfang Zhang
no flags Details
dump analysis file for 2k8r2 bsod in virtio-win-1.1.13-0 (4.90 KB, text/plain)
2010-09-02 04:04 EDT, Qunfang Zhang
no flags Details

  None (edit)
Comment 2 Qunfang Zhang 2010-08-23 04:39:23 EDT
This issue does not exist on virtio-win-1.1.7-2. So it's a regression.
During the version virtio-win-1.1.8-0 ~ virtio-win-1.1.11-0, serial test is blocked by Bug 613949 and Bug 614722.
Comment 4 Vadim Rozenfeld 2010-08-23 04:47:33 EDT
what is the qemu command line?
Thanks,
Vadim.
Comment 5 Qunfang Zhang 2010-08-23 04:51:28 EDT
(In reply to comment #4)
> what is the qemu command line?
> Thanks,
> Vadim.
Sorry, forgot to paste it.

 /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu qemu64,+x2apic -usbdevice tablet -drive file=win2k8-r2-serial.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none   -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup0 -device e1000,netdev=hostnet0,mac=00:10:42:3F:76:1C,bus=pci.0,addr=0x4,id=net0 -boot c -uuid 37ebf1b7-7195-43d6-8404-1a2a6129e3fc  -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -name win2k8-r2-serial-176  -spice port=5930,disable-ticketing -vga qxl  -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=4,bus=pci.0 -chardev pty,id=channel0 -device virtserialport,chardev=channel0,name=org.linux-kvm.port.0,bus=virtio-serial0.0
Comment 6 Vadim Rozenfeld 2010-08-23 05:35:58 EDT
Hi, Qunfang.
Could you please re-test two slightly different configurations:
1. the same command line, but "-smp 1"
2. the same command lime, but "-smp 2", and no qxl device?

Thanks,
Vadim.
Comment 7 Qunfang Zhang 2010-08-23 07:44:31 EDT
(In reply to comment #6)
> Hi, Qunfang.
> Could you please re-test two slightly different configurations:
> 1. the same command line, but "-smp 1"
> 2. the same command lime, but "-smp 2", and no qxl device?
> 
> Thanks,
> Vadim.

Hi, Vadim
Tested the above 2 different configurations. Both got BSOD and the error code is still 0x9F.
Comment 8 Qunfang Zhang 2010-08-23 07:52:13 EDT
BTW, tested win7-64, has the same problem.
Comment 9 Vadim Rozenfeld 2010-08-23 08:07:35 EDT
Can you please try it on any 32-bit OS?
And, any chance of seeing DTM report file?

Thanks & best regards,
Vadim.
Comment 10 Qunfang Zhang 2010-08-23 08:14:48 EDT
(In reply to comment #9)
> Can you please try it on any 32-bit OS?
> And, any chance of seeing DTM report file?
> 
> Thanks & best regards,
> Vadim.

OK, will update result after finish. But because it got BSOD so we can not get a DTM report file.
Comment 11 Vadim Rozenfeld 2010-08-23 08:29:08 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > Can you please try it on any 32-bit OS?
> > And, any chance of seeing DTM report file?
> > 
> > Thanks & best regards,
> > Vadim.
> 
> OK, will update result after finish. But because it got BSOD so we can not get
> a DTM report file.

OK, thanks.
Comment 12 Vadim Rozenfeld 2010-08-23 09:12:05 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > Can you please try it on any 32-bit OS?
> > And, any chance of seeing DTM report file?
> > 
> > Thanks & best regards,
> > Vadim.
> 
> OK, will update result after finish. But because it got BSOD so we can not get
> a DTM report file.

Could it be that you have spice agent installed on your system?
Comment 13 Vadim Rozenfeld 2010-08-23 09:25:03 EDT
(In reply to comment #12)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > Can you please try it on any 32-bit OS?
> > > And, any chance of seeing DTM report file?
> > > 
> > > Thanks & best regards,
> > > Vadim.
> > 
> > OK, will update result after finish. But because it got BSOD so we can not get
> > a DTM report file.
> 
> Could it be that you have spice agent installed on your system?

Qunfang,
could you please try running the tests without any virtserialport device, only virtio-serial-pci?

Thank you,
Vadim.
Comment 14 Qunfang Zhang 2010-08-24 01:41:04 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > (In reply to comment #10)
> > > (In reply to comment #9)
> > > > Can you please try it on any 32-bit OS?

Tested win7-32 with the same command line in Comment 5, got the same BSOD.

> > > > And, any chance of seeing DTM report file?
> > > > 
> > > > Thanks & best regards,
> > > > Vadim.
> > > 
> > > OK, will update result after finish. But because it got BSOD so we can not get
> > > a DTM report file.
> > 
> > Could it be that you have spice agent installed on your system?
Hi, Vadim, when we got BSOD, can only "system_reset" guest in the qemu monitor, and we can not get the DTM report log, whenever I use vnc or spice.

> 
> Qunfang,
> could you please try running the tests without any virtserialport device, only
> virtio-serial-pci?
> 

Tested without virtserialport device, only use virtio-serial-pci, still got BSOD.

> Thank you,
> Vadim.
Comment 18 Vadim Rozenfeld 2010-08-30 18:17:09 EDT
please check with the latest drivers from 
http://download.lab.bos.redhat.com/devel/RHEV/virtio-win/mm21/

Please check two different scenarios: 
- vioserial device only, without any port device;
- vioserial device with one or two port devices.

Thanks,
Vadim.
Comment 22 Jay Greguske 2010-08-31 12:14:28 EDT
*** Bug 627577 has been marked as a duplicate of this bug. ***
Comment 23 Qunfang Zhang 2010-09-01 00:50:35 EDT
(In reply to comment #18)
> please check with the latest drivers from 
> http://download.lab.bos.redhat.com/devel/RHEV/virtio-win/mm21/
> 
> Please check two different scenarios: 
> - vioserial device only, without any port device;
Test with the driver, and this bug does not exist in win2k8-R2.

> - vioserial device with one or two port devices.
The job will take many hours, so we continue to test without port devices for other jobs and guests. and try to get all guests' vioserial result for submission.

> Thanks,
> Vadim.
Comment 25 Qunfang Zhang 2010-09-02 04:04:52 EDT
Created attachment 442567 [details]
dump  analysis file for 2k8r2 bsod in virtio-win-1.1.13-0
Comment 29 Vadim Rozenfeld 2010-09-09 15:41:07 EDT
Please check with the latest drivers from
http://download.lab.bos.redhat.com/devel/RHEV/virtio-win/1.1.14-0/
Comment 32 Jay Greguske 2010-09-27 15:46:08 EDT
The long-awaited RPM with these new drivers is now available:

https://brewweb.devel.redhat.com/buildinfo?buildID=144698
Comment 36 releng-rhel@redhat.com 2010-11-11 10:01:41 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.