Bug 62634 - RPM confusing error message
RPM confusing error message
Status: CLOSED DUPLICATE of bug 62597
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-03 11:28 EST by Ben Woodard
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 11:28:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Woodard 2002-04-03 11:28:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020326

Description of problem:
This bug may be similar to Bug 20286 which in turn is similar to 2895. However,
this one is much more specific and therefore may have a chance of being fixed. ;-)

If you do not have the rpm-build package installed and try to build a package
you get a confusing error message. For example:

[root@test1 SPECS]# rpm -bp kernel-2.4.spec
kernel-2.4.spec: No such file or directory

when the file kernel-2.4.spec is right there. Strace allows you to realize that
the error message is coming from the fact that rpmb is not being exec'd properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -e rpm-build
2.rpm -Uvh anything.src.rpm
3.rpm -ba /usr/src/redhat/SPECS/anything.spec
	

Actual Results:  anything.spec: No such file or directory


Expected Results:  rpmb: No such file or directory
Please install the rpm-build rpm.

Additional info:
Comment 1 Jeff Johnson 2002-04-03 17:02:51 EST

*** This bug has been marked as a duplicate of 62597 ***

Note You need to log in before you can comment on or make changes to this bug.