Bug 626377 - dhcpv4 does not allow records from dhcpv6 to be added to the zones
Summary: dhcpv4 does not allow records from dhcpv6 to be added to the zones
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-23 12:09 UTC by Eddie Lania
Modified: 2010-08-25 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 11:33:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eddie Lania 2010-08-23 12:09:11 UTC
Description of problem: Enabling DHCPDv6 on the network causes the problem that when running both dhcpv4 and v6 services on the same server, dhcp service does not allow for an exsisting v4 record to be updated with v6:

Aug 23 13:41:14 ls2ka dhcpd: DHCPDISCOVER from f4:ce:46:3d:55:62 via eth0
Aug 23 13:41:15 ls2ka dhcpd: DHCPOFFER on 192.168.168.13 to f4:ce:46:3d:55:62 (NPI3D5562) via eth0
Aug 23 13:41:19 ls2ka named[13070]: client 192.168.168.3#35690: updating zone 'elton-intra.net/IN': adding an RR at 'NPI3D5562.elton-intra.net' A
Aug 23 13:41:19 ls2ka named[13070]: client 192.168.168.3#35690: updating zone 'elton-intra.net/IN': adding an RR at 'NPI3D5562.elton-intra.net' TXT
Aug 23 13:41:20 ls2ka named[13070]: zone elton-intra.net/IN: sending notifies (serial 65586)
Aug 23 13:41:20 ls2ka dhcpd: Added new forward map from NPI3D5562.elton-intra.net to 192.168.168.13
Aug 23 13:41:20 ls2ka named[13070]: client 192.168.168.3#35310: updating zone '168.168.192.in-addr.arpa/IN': deleting rrset at '13.168.168.192.in-addr.arpa' PTR
Aug 23 13:41:20 ls2ka named[13070]: client 192.168.168.3#35310: updating zone '168.168.192.in-addr.arpa/IN': adding an RR at '13.168.168.192.in-addr.arpa' PTR
Aug 23 13:41:20 ls2ka named[13070]: zone 168.168.192.in-addr.arpa/IN: sending notifies (serial 1997111065)
Aug 23 13:41:20 ls2ka dhcpd: added reverse map from 13.168.168.192.in-addr.arpa. to NPI3D5562.elton-intra.net
Aug 23 13:41:20 ls2ka dhcpd: DHCPREQUEST for 192.168.168.13 (192.168.168.3) from f4:ce:46:3d:55:62 (NPI3D5562) via eth0
Aug 23 13:41:20 ls2ka dhcpd: DHCPACK on 192.168.168.13 to f4:ce:46:3d:55:62 (NPI3D5562) via eth0
Aug 23 13:41:58 ls2ka dhcpd: Solicit message from fe80::f6ce:46ff:fe3d:5562 port 546, transaction ID 0xA37D0000
Aug 23 13:41:58 ls2ka dhcpd: Sending Advertise to fe80::f6ce:46ff:fe3d:5562 port 546
Aug 23 13:41:58 ls2ka dhcpd: Request message from fe80::f6ce:46ff:fe3d:5562 port 546, transaction ID 0x735C0000
Aug 23 13:41:58 ls2ka dhcpd: data: leased_lease: not available
Aug 23 13:41:58 ls2ka named[13070]: client 192.168.168.3#32899: updating zone 'elton-intra.net/IN': update unsuccessful: NPI3D5562.elton-intra.net: 'name not in use' prerequisite not satisfied (YXDOMAIN)
Aug 23 13:41:58 ls2ka named[13070]: client 192.168.168.3#43688: updating zone 'elton-intra.net/IN': update unsuccessful: NPI3D5562.elton-intra.net/TXT: 'RRset exists (value dependent)' prerequisite not satisfied (NXRRSET)
Aug 23 13:41:58 ls2ka dhcpd: Forward map from NPI3D5562.elton-intra.net to fdf5:a3af:1d9a::1f4 FAILED: Has an address record but no DHCID, not mine.
Aug 23 13:41:58 ls2ka dhcpd: data: leased_lease: not available
Aug 23 13:41:58 ls2ka named[13070]: client 192.168.168.3#49077: updating zone 'elton-intra.net/IN': update unsuccessful: NPI3D5562.elton-intra.net: 'name not in use' prerequisite not satisfied (YXDOMAIN)
Aug 23 13:41:58 ls2ka named[13070]: client 192.168.168.3#47770: updating zone 'elton-intra.net/IN': update unsuccessful: NPI3D5562.elton-intra.net/TXT: 'RRset exists (value dependent)' prerequisite not satisfied (NXRRSET)
Aug 23 13:41:58 ls2ka dhcpd: Forward map from NPI3D5562.elton-intra.net to fdf5:a3af:1d9a::1f4 FAILED: Has an address record but no DHCID, not mine.
Aug 23 13:41:58 ls2ka dhcpd: Sending Reply to fe80::f6ce:46ff:fe3d:5562 port 546


Version-Release number of selected component (if applicable):
dhcp-4.1.1-23.P1.fc13.i686


How reproducible: All the time


Steps to Reproduce:
1. Install dhpd v4 and v6
2. Configure them to reply to queries and update the dns (DDNS)
3.
  
Actual results: Can't update both v4 and v6 on the same server


Expected results: Succesful updates to be preformed for both ipv4 and ipv6 address records.


Additional info:

Comment 1 Eddie Lania 2010-08-24 15:22:27 UTC
I assume this is being caused by the fact that i am not using the "ignore-client-updates;" option in dhcpd.conf? And that that is why a "TXT" record is being added for every dhcpv4 client that is not updating the dns records itself?

And if I am supposed to add the "ignore-client-updates;" option to the dhcpd.conf, will I have to manually remove the "TXT" records for those clients from the zone file? And also remove those client's entries from the dhcpd.leases file as well?

Please help me.

regards,

Eddie.

Comment 2 Jiri Popelka 2010-08-24 15:36:12 UTC
Hello Eddie,

I'm afraid I don't have any answer for you at the moment,
cause I don't have any spare time to investigate this right now.
The best you can do is to try the dhcp-users mailing list.
https://lists.isc.org/mailman/listinfo/dhcp-users

Comment 3 Jiri Popelka 2010-08-25 11:33:43 UTC
Closing as 'upstream' per David W. Hankins' response
https://lists.isc.org/pipermail/dhcp-users/2010-August/011865.html


Note You need to log in before you can comment on or make changes to this bug.