Bug 62648 - Takes to long to load, Crashes when PHP Debug is turned off.
Takes to long to load, Crashes when PHP Debug is turned off.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: quanta (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-03 14:05 EST by Scott Dowdle
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 05:46:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2002-04-03 14:05:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux 2.4.9-31; X11; i686; en_US)

Description of problem:
quanta-2.1-0.cvs20020307.1 takes a LONG time (over a minute on a fast machine) to load with the production KDE 3.0 that was released recently (today?).  It appears to be trying to automatically connect to a PHP debugger server or something.  Going into Quanta settings and trying to disable the debugger crashes the program upon clicking the OK button dialog box for PHP settings.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load Quanta (from konsole shell so we can see what is going on) an wait
2. Splash screen appears and stays for a long time
3. Eventually opens program window after complaining a lot
4. Crashes (nicely with KDE Crash window) when attempting to disable the PHP debugger under Settings->Configure Quanta->PHP Debug dialog box.

Actual Results:  Takes a long time to load.
Can't disable PHP debugger from built in GUI Quanta Configuration

Expected Results:  Should load a lot faster and shouldn't crash.  I don't think PHP Debugger should be on by default.

I will try to read Quanta docs to see if there is a command line option I can disable PHP Debugger with ...or by manually editing it's config file (wherever it is, haven't looked yet).

Additional info:

Output from shell window during load and crash (caused by disabling PHP debugger):
QToolBar::QToolBar main window cannot be 0.
QToolBar::QToolBar main window cannot be 0.
QToolBar::QToolBar main window cannot be 0.
QToolBar::QToolBar main window cannot be 0.
QToolBar::QToolBar main window cannot be 0.
QToolBar::QToolBar main window cannot be 0.
QGDict::hashKeyString: Invalid null key
parseBlock(0x856a930)
KWBufBlock: buildStringList this = 0x856a930
dirtyBlock(0x856a930)
KWBufBlock: disposeRawData this = 0x856a930
QObject::connect: No such signal KWrite::scrollValueChanged(int)
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'unnamed')
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = quanta path = <unknown> pid = 12415
Comment 1 Bernhard Rosenkraenzer 2002-04-04 05:46:18 EST
I can reproduce the crash when turning PHP Debug off and the debug spewage on the console 
it's started from, but it starts up almost instantly about (2 seconds) here. 
By any chance, are you low on memory?
Comment 2 Bernhard Rosenkraenzer 2002-04-04 10:48:47 EST
Fixed in 2.1-0.cvs20020404.1

Note You need to log in before you can comment on or make changes to this bug.