Bug 626481 - ypbind rpm test fails on configfile
Summary: ypbind rpm test fails on configfile
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypbind   
(Show other bugs)
Version: 4.9
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Karel Klíč
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-23 16:23 UTC by Juraj Marko
Modified: 2015-09-01 03:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 14:50:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Juraj Marko 2010-08-23 16:23:41 UTC
Description of problem:
rpm verification fails for ypbind

Version-Release number of selected component (if applicable):
ypbind-1.17.2-14
ypbind-1.17.2-13

How reproducible:
100%

Steps to Reproduce:
1. install ypbind
2. edit /etc/yp.conf
3.# rpm -V ypbind-1.17.2-14
  S.5....T. c /etc/yp.conf
  
Actual results:
fails after edit configfile

Expected results:
not fails after edit configfile

Additional info:
http://nest.test.redhat.com/mnt/qa/scratch/ppcp-4as-v1/2010:9711/tps/tps-rpmtest.html

Comment 1 Karel Klíč 2010-09-06 13:51:09 UTC
Why should `rpm -V ypbind` suppress the information that the config file has been changed from what is in the RPM file?

Comment 2 Ondrej Vasik 2011-02-22 14:50:28 UTC
This is not a bug, rpm should notify the user about the change. Config file is marked noreplace in spec file, so the user's configuration will not be replaced by update. Expected behaviour of noreplace flag.


Note You need to log in before you can comment on or make changes to this bug.