Bug 626654 - systemctl is in systemd-units
Summary: systemctl is in systemd-units
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-24 02:11 UTC by Bill Nottingham
Modified: 2014-03-17 03:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 19:02:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2010-08-24 02:11:19 UTC
Description of problem:

Shouldn't in be in the main systemd package?

Version-Release number of selected component (if applicable):

systemd-units-7-3.fc14.x86_64

Comment 1 Lennart Poettering 2010-08-24 19:02:27 UTC
No, this is intended this way: the -units package exists so that packages can depend on it without actually pulling in the main systemd package.

For this to work the units package contains exactly what is is necessary for the %post rpm scripts which install systemd services files to work: the unit directories where to place the units in, a few dependencies and the systemctl tool which is used to remove/create symlinks.


Note You need to log in before you can comment on or make changes to this bug.