Bug 626840 - "isolate" may not be the most clear term for that systemctl action
"isolate" may not be the most clear term for that systemctl action
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 10:34 EDT by Matthew Miller
Modified: 2010-08-27 10:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 09:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2010-08-24 10:34:18 EDT
The command "systemctl isolate [whatever].target" means to make just that target be active, and nothing else.

However, the word "isolate" has negative connotations: it can be synonymous with quarantine. Thus, when I run "systemctl isolate graphical.target", my intuition is that this will somehow deactivate and put away from everything else the graphical target.

This is made more confusing by the fact that systemctl is a do-everything program, with actions that both change the current state and actions which change the configuration -- that is, it's not unreasonable to think that there might be a systemctl command that does in fact super-disable the target in some way.

I am marking this as low priority because I don't think it's a deal-breaker; people have learned what stranger command names do. I just wanted to alert you to this possible reaction.
Comment 1 Michal Schmidt 2010-08-24 11:31:53 EDT
Do you have any suggestions for a better name?
Comment 2 Matthew Miller 2010-08-24 12:05:26 EDT
(In reply to comment #1)
> Do you have any suggestions for a better name?

How about "switch-to"?
Comment 3 Matthew Miller 2010-08-24 12:15:34 EDT
Another reason isolate is confusing is that it doesn't isolate a single target (which would generally be useless): it runs that target and everything that target depends on. That's completely sensible behavior, but the name seems to imply otherwise.
Comment 4 Lennart Poettering 2010-08-24 14:44:04 EDT
Note sure I am convinced that "switch-to" would be a better name. This isn't really a switch you could flip. Reading "switch-to" I'd implicitly assume that you'd have to pick exactly one unit to switch to, which however is not really true, as one unit might pull another one it. I think "isolate" describes much better that you isolate (i.e. as in "separate") one specific unit (and its deps) from everything else.

I am open to finding a different name, but if we do the work it must be a really convincing name, and "switch-to" I don't think is really that optimal.
Comment 5 Lennart Poettering 2010-08-24 14:44:41 EDT
Setting this to NEED-INFO as I won't change anything without a very good alternative suggestion.
Comment 6 Bill Nottingham 2010-08-24 14:53:08 EDT
I prefer 'switch-to' or 'activate' to 'isolate'. You appear to have co-opted activate already as a synonoym for start, though.

A concern I have is that the operation here is made available as an option for all units (if I'm reading the man page right), but it only really makes sense for a small subset of them.
Comment 7 Matthew Miller 2010-08-24 15:04:46 EDT
(In reply to comment #4)
> Note sure I am convinced that "switch-to" would be a better name. This isn't
> really a switch you could flip. Reading "switch-to" I'd implicitly assume that

The word "switch" doesn't strongly imply that there is a binary operation (despite its use in the sense of light switch). It means "change".

> you'd have to pick exactly one unit to switch to, which however is not really
> true, as one unit might pull another one it. I think "isolate" describes much
> better that you isolate (i.e. as in "separate") one specific unit (and its
> deps) from everything else.

The ambiguity is "what is everything else". The implication of the word is that you isolate something and put it away from the world (as in quarantine, or an isolation cell), not that you select it for active use.
Comment 8 Bill Nottingham 2010-08-24 15:09:56 EDT
Speaking of... 'select'?
Comment 9 Matthew Miller 2010-08-24 15:16:24 EDT
Or "change-to".
Comment 10 Matthew Miller 2010-08-25 11:55:08 EDT
See bug #625409 for an example of a confused user who didn't notice "isolate" as the correct term.
Comment 11 Rahul Sundaram 2010-08-25 12:40:17 EDT
FWIW,  I completely agree.  "isolate" and "maintenance" are two works people get confused about when I demo systemd to them on my system these days.  Both these words must be changed to something else IMO.  I like "select" because "selecting a target" is a natural workflow.  Instead of "maintenance", I would suggest "broken" as well.
Comment 12 Lennart Poettering 2010-08-26 18:25:57 EDT
Hmm, I actually think if you really want to change this, then Bill's suggestion of "select" is nicer than "switch-to", since it's a single word. OTOH both are words that mean all and nothing I think?
Comment 13 Matthew Miller 2010-08-26 19:34:07 EDT
I like switch-to better, because to me it imples something that will happen actively right now, in a way that select doesn't. (You often "select" something to use later.) But I like both of them better than isolate. :)
Comment 14 Lennart Poettering 2010-08-27 07:59:14 EDT
"single-out"?
Comment 15 Lennart Poettering 2010-08-27 08:01:05 EDT
"discriminate"
Comment 16 Lennart Poettering 2010-08-27 08:03:00 EDT
"abstract, block  off,  close  off,  confine, detach, disconnect, disengage,  divide, divorce,  insulate,  island, keep  apart,  part, quarantine, remove, seclude,  segregate, separate, sequester, sever, sunder"
Comment 17 Lennart Poettering 2010-08-27 08:03:36 EDT
"accept, adopt, appoint, call  for,  cast, co-opt,  commit  oneself,  crave, cull, decide  on,  designate, desire, determine, discriminate  between,  draw  lots,  elect,  embrace, espouse, excerpt, extract, fancy, favor, feel  disposed  to,  finger, fix  on,  glean, judge, love, make  choice,  make  decision,  make  up  one's  mind,  name, opt  for,  predestine,  prefer, see  fit,  separate, set  aside,  settle  upon,  sift  out,  single  out  , slot,  sort, tab,  tag, take, take up, tap, want, weigh,  will, winnow,  wish, wish  for"
Comment 18 Lennart Poettering 2010-08-27 08:03:51 EDT
"pick"
Comment 19 Matthew Miller 2010-08-27 08:17:43 EDT
Wow. :)
Comment 20 Matthew Miller 2010-08-27 08:21:30 EDT
So, to take that seriously: note how the list in comment #16 tends to have negative connotations implying getting rid of something. That's what I want to avoid with "isolate".
Comment 21 Matthew Miller 2010-08-27 08:29:43 EDT
Just to throw another one out there, there's always "runlevel". :)
Comment 22 Lennart Poettering 2010-08-27 09:51:06 EDT
The list of words comes from a thesaurus btw.

I have discussed this now in length with Kay, and we came to the conclusion that not a single of the suggested words is as descriptive for what actually happens as isolate, and so we decided not to make a change here.

I will close this bug now, feel free to reopen if you have a suggestion that as neatly as "isolate" describes what actually happens.

And Kay said I should blame it on him, if people are discontent with this decision. So, blame Kay, not me! ;-)

Sorry.
Comment 23 Matthew Miller 2010-08-27 10:20:14 EDT
I'm gonna go bug Kay, then. :) I think your thesaurus list illustrates the problem quite well.

Note You need to log in before you can comment on or make changes to this bug.