Bug 626882 - Could not find debuginfo for main pkg: pidgin-2.7.1-2.fc13.x86_64
Could not find debuginfo for main pkg: pidgin-2.7.1-2.fc13.x86_64
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 12:02 EDT by Timur Tabi
Modified: 2010-08-24 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 20:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timur Tabi 2010-08-24 12:02:33 EDT
I'm trying to report a crash in Pidgin, but abrt won't let me because I don't have debuginfo for pidgin installed.  But when I try to install debuginfo, I get an error message:

# debuginfo-install pidgin 
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
enabling updates-debuginfo
enabling rpmfusion-free-debuginfo
enabling fedora-debuginfo
enabling rpmfusion-free-updates-debuginfo
Found 46 installed debuginfo package(s)
Found 46 installed debuginfo package(s)
Could not find debuginfo for main pkg: pidgin-2.7.1-2.fc13.x86_64
Package libICE-debuginfo-1.0.6-2.fc13.x86_64 already installed and latest version
Package libSM-debuginfo-1.1.0-7.fc12.x86_64 already installed and latest version
Package libX11-debuginfo-1.3.1-3.fc13.x86_64 already installed and latest version
Package libXext-debuginfo-1.1-2.fc13.x86_64 already installed and latest version
Package libXScrnSaver-debuginfo-1.2.0-1.fc12.x86_64 already installed and latest version
Package atk-debuginfo-1.30.0-1.fc13.x86_64 already installed and latest version
Package cairo-debuginfo-1.8.10-1.fc13.x86_64 already installed and latest version
Package 1:dbus-debuginfo-1.2.24-1.fc13.x86_64 already installed and latest version
Package dbus-glib-debuginfo-0.84-3.fc13.x86_64 already installed and latest version
Package fontconfig-debuginfo-2.8.0-1.fc13.x86_64 already installed and latest version
Package freetype-debuginfo-2.3.11-3.fc13.x86_64 already installed and latest version
Package gtk2-debuginfo-2.20.1-1.fc13.x86_64 already installed and latest version
Package gtk2-debuginfo-2.20.1-1.fc13.x86_64 already installed and latest version
Package glib2-debuginfo-2.24.1-1.fc13.x86_64 already installed and latest version
Package glib2-debuginfo-2.24.1-1.fc13.x86_64 already installed and latest version
Package glib2-debuginfo-2.24.1-1.fc13.x86_64 already installed and latest version
Package glib2-debuginfo-2.24.1-1.fc13.x86_64 already installed and latest version
Could not find debuginfo pkg for dependency package gstreamer-0.10.29-2.fc13.x86_64
Could not find debuginfo pkg for dependency package farsight2-0.0.18-1.fc13.x86_64
Could not find debuginfo pkg for dependency package gstreamer-plugins-base-0.10.29-1.fc13.x86_64
Could not find debuginfo pkg for dependency package gstreamer-0.10.29-2.fc13.x86_64
Package glib2-debuginfo-2.24.1-1.fc13.x86_64 already installed and latest version
Package gtk2-debuginfo-2.20.1-1.fc13.x86_64 already installed and latest version
Package gtkspell-debuginfo-2.0.16-1.fc13.x86_64 already installed and latest version
Package libidn-debuginfo-1.16-1.fc13.x86_64 already installed and latest version
Package pango-debuginfo-1.28.0-1.fc13.x86_64 already installed and latest version
Package pango-debuginfo-1.28.0-1.fc13.x86_64 already installed and latest version
Package pango-debuginfo-1.28.0-1.fc13.x86_64 already installed and latest version
Could not find debuginfo pkg for dependency package libpurple-2.7.1-2.fc13.x86_64
Package startup-notification-debuginfo-0.10-4.fc13.x86_64 already installed and latest version
Package libxml2-debuginfo-2.7.7-1.fc13.x86_64 already installed and latest version
No debuginfo packages available to install

Here are the pidgin packages I have installed:

# rpm -qa | grep pidgin
pidgin-2.7.1-2.fc13.x86_64
pidgin-evolution-2.7.1-2.fc13.x86_64
pidgin-sipe-1.9.1-1.fc13.x86_64
Comment 1 Stu Tomlinson 2010-08-24 14:46:09 EDT
You should update to the latest pidgin first and see if the crash/bug isn't fixed already.
Comment 2 Timur Tabi 2010-08-24 17:41:51 EDT
What are you talking about?  I am running the latest pidgin.  I have auto-update enabled, and "yum update pidgin" said there was nothing to update.

Please don't think I'd be dumb enough to file a bug report without making sure I'm running the latest version of the code first.
Comment 3 Stu Tomlinson 2010-08-24 20:58:16 EDT
(In reply to comment #2)
> What are you talking about?  I am running the latest pidgin.

No, you're not:
https://admin.fedoraproject.org/updates/pidgin-2.7.3-1.fc13
https://admin.fedoraproject.org/updates/pidgin-sipe-1.10.1-1.fc13

> I have
> auto-update enabled, and "yum update pidgin" said there was nothing to update.
> 
> Please don't think I'd be dumb enough to file a bug report without making sure
> I'm running the latest version of the code first.

I didn't think you were being dumb, sorry if that's the impression you got. I'd expect "yum update pidgin" to work, but please also see:
http://lists.fedoraproject.org/pipermail/announce/2010-July/002843.html

Maybe you somehow disabled your fedora-updates repo? check /etc/yum.repos.d/fedora-updates.repo

Either way though, without a usable crash report there's still not enough information available to address this.
Comment 4 Timur Tabi 2010-08-24 21:42:55 EDT
Ok, I'm not sure what's broken on my system.  'yum repolist' says this:

Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Found 46 installed debuginfo package(s)
Enabling updates-debuginfo: Fedora 13 - x86_64 - Updates - Debug
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 13 - Free - Debug
Enabling fedora-debuginfo: Fedora 13 - x86_64 - Debug
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 13 - Free - Updates Debug
repo id                          repo name                                status
fedora                           Fedora 13 - x86_64                       20,840
fedora-debuginfo                 Fedora 13 - x86_64 - Debug                5,142
fedora-source                    Fedora 13 - Source                            0
rpmfusion-free                   RPM Fusion for Fedora 13 - Free             457
rpmfusion-free-debuginfo         RPM Fusion for Fedora 13 - Free - Debug       0
rpmfusion-free-updates           RPM Fusion for Fedora 13 - Free - Update    391
rpmfusion-free-updates-debuginfo RPM Fusion for Fedora 13 - Free - Update    132
updates                          Fedora 13 - x86_64 - Updates              2,940
*updates-debuginfo               Fedora 13 - x86_64 - Updates - Debug      1,144
repolist: 31,046

and 'yum -y --skip-broken update' also says everything is up-to-date.
Comment 5 Stu Tomlinson 2010-08-24 22:06:54 EDT
I can't say what is wrong with your system, it's pretty much beyond my knowledge as a contributor to the packaging of Pidgin, but I can say that on my F13 x86_64 system the "updates" repo has 6,072 available packages - much more than your 2,940. Maybe a "yum clean all" followed by "yum update" will help, but maybe that will leave you with even fewer updates available - I'd recommend you seek more generic update assistance. Or try disabling the "auto-update-debuginfo" yum plugin.

(also note that using --skip-broken by definition will exclude updates that can't be satisfied due to incompatible updates, but based on the repos you listed there shouldn't be many of those).

Note You need to log in before you can comment on or make changes to this bug.