Bug 62696 - IDE interface not enabled
Summary: IDE interface not enabled
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-04 15:35 UTC by Kjartan Maraas
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-30 22:49:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci (4.33 KB, text/plain)
2002-04-04 15:36 UTC, Kjartan Maraas
no flags Details
Output from dmesg (8.09 KB, text/plain)
2002-04-04 15:37 UTC, Kjartan Maraas
no flags Details

Description Kjartan Maraas 2002-04-04 15:35:35 UTC
Description of Problem:
The ide interface is not being enabled on my Compaq Evo N600c laptop.

Version-Release number of selected component (if applicable):


How Reproducible:
Every time.

Steps to Reproduce:
1. run hdparm -d1 /dev/hda
2. dmesg shows that the device is not being enabled properly.
3. 

Actual Results:
HDIO_SET_DMA failed: Operation not permitted

Expected Results:
Working DMA on HDA

Additional Information:
Attaching lspci output and dmesg output.

Comment 1 Kjartan Maraas 2002-04-04 15:36:44 UTC
Created attachment 52205 [details]
output from lspci

Comment 2 Kjartan Maraas 2002-04-04 15:37:45 UTC
Created attachment 52206 [details]
Output from dmesg

Comment 3 Kjartan Maraas 2002-04-17 13:11:18 UTC
Tried the latest rawhide kernels with no success. Also updated to latest BIOS
from Compaq.

Comment 4 John Cagle 2002-04-20 04:35:05 UTC
Looks like it's just DMA thats not being enabled.
Try adding "ide=ata66" to your kernel command line.

Comment 5 Kjartan Maraas 2002-04-20 05:39:01 UTC
Already tried that with no success. The bit about resource collitions is the one
that worries me I think?

Comment 6 Kjartan Maraas 2002-04-20 05:41:10 UTC
Addng CC: to make sure the feedback get back to people trying to help. (John, I
relplied to your suggestion before remembering to put you in the CC:, in short
ide0=ata66 doesn't help)

Comment 7 Kjartan Maraas 2002-04-30 22:49:48 UTC
Solved by the latest patch from http://linuxdiskcert.org/ :)

Comment 8 Kjartan Maraas 2002-06-17 00:17:58 UTC
Fixed in Milan beta1 at least.


Note You need to log in before you can comment on or make changes to this bug.