Bug 626983 - poor NFS client performance on SMP and EL5
poor NFS client performance on SMP and EL5
Status: CLOSED DUPLICATE of bug 519126
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Jeff Layton
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 15:20 EDT by Herbert van den Bergh
Modified: 2014-12-18 04:25 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-04 07:15:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NFS client BKL removal (86.41 KB, patch)
2010-08-24 15:21 EDT, Herbert van den Bergh
no flags Details | Diff
tarball with patches split into individual files (18.07 KB, application/octet-stream)
2010-10-05 08:17 EDT, Jeff Layton
no flags Details
patch -- forward ported patch (56.28 KB, patch)
2011-03-28 14:35 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Herbert van den Bergh 2010-08-24 15:20:24 EDT
Contention for the BKL in NFS client code, combined with
CONFIG_PREEMPT_BKL being enabled in EL5, causes severe overhead on SMP
systems in scheduling and locking code.  The patch stream backported from
upstream modifies the NFS client code to remove the BKL contention.
Comment 1 Herbert van den Bergh 2010-08-24 15:21:38 EDT
Created attachment 440741 [details]
NFS client BKL removal
Comment 2 Jeff Layton 2010-10-05 08:17:47 EDT
Created attachment 451651 [details]
tarball with patches split into individual files

Tarball with patches split out as individual files. There are some definite merge conflicts with 5.6-ish kernels, so this will take some work if we want to go with this.
Comment 3 Jeff Layton 2010-10-07 09:30:23 EDT
I've forward ported the patches to more recent kernels and have test kernels on my people.redhat.com pages. Any testing of them would be appreciated:

http://people.redhat.com/jlayton/
Comment 4 Jeff Layton 2010-12-04 06:59:21 EST
I've experimented with these patches over the last several months and haven't seen any problems. That said, they make me really nervous. This is just the sort of thing that can cause subtle, difficult to detect regressions.

At this point, I think this is too risky, especially given that RHEL6 has most of this already. For now I'm going to NAK this bug, and suggest that anyone that's hitting this problem consider a move to RHEL6.
Comment 5 RHEL Product and Program Management 2010-12-04 07:15:09 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 6 Jeff Layton 2011-03-28 14:35:20 EDT
Created attachment 488222 [details]
patch -- forward ported patch

For the record, here's the patchset I was playing with when I was considering this, if anyone is interested...
Comment 9 Harshula Jayasuriya 2014-12-18 04:25:50 EST

*** This bug has been marked as a duplicate of bug 519126 ***

Note You need to log in before you can comment on or make changes to this bug.