Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 627043 - HWCert: RedHat v7-1.2-16 network test on sit0 interface fails on RHEL6.0 beta2 (snap10)
HWCert: RedHat v7-1.2-16 network test on sit0 interface fails on RHEL6.0 beta...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.2
ppc64 All
low Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 18:40 EDT by IBM Bug Proxy
Modified: 2015-02-08 16:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.2, a problem has been observed that network test included sit0 interface which is not necessarily required for testing. This issue has been fixed in v7 1.3, now sit0 interface is no longer planned nor executed during network testing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 12:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network test output (222.89 KB, text/plain)
2010-08-24 18:40 EDT, IBM Bug Proxy
no flags Details
network test patch adding "sit" to the list of interfaces to ignore (614 bytes, patch)
2011-01-26 12:02 EST, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 66674 None None None Never
Red Hat Product Errata RHBA-2011:0497 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-05-09 12:11:16 EDT

  None (edit)
Description IBM Bug Proxy 2010-08-24 18:40:47 EDT
-- Problem description --
The network test fails on sit0 interface.

Steps to reproduce:

1. v7 run --test=network --server 10.1.1.9

The output of sit0 test:

mkdir -p /tmp/v7-network-QnhUsT/mnt/tests/V7/v7/network
cp -a testinfo.desc runtest.sh network.py Makefile
/tmp/v7-network-QnhUsT/mnt/tests/V7/v7/network
install -m 0755 runtest.sh /tmp/v7-network-QnhUsT/mnt/tests/V7/v7/network
chmod a+x ./runtest.sh ./network.py
./runtest.sh
/tmp/v7-network-QnhUsT/mnt/tests/V7/v7/network/network.py
<output>
Running ./network.py:
<output name="Setup" description="prepare for network testing">
using test server 10.1.1.9
Testing interface sit0
ignoring interface lo
ignoring interface virbr0
<summary>PASS</summary>
</output>
<output name="Interface Configuration" description="None">
usage: ifdown <device name>
/sbin/ifup: configuration for sit0 not found.
Usage: ifup <device name>
Warning: could not shut down interface sit0
Interface sit0 is down
Bringing up interface sit0
ifup sit0 returned 256
Error: could not restart interface sit0
Error: could not bounce interface sit0
<summary>FAIL</summary>
</output>
...finished running ./network.py, exit code=1
</output>
recovered exit code=1
v7-report-result /V7/v7/network FAIL /var/log/v7/runs/8/network/output.log 
mkdir -p /tmp/v7-network-UVkds6/mnt/tests/V7/v7/network
cp -a testinfo.desc runtest.sh network.py Makefile
/tmp/v7-network-UVkds6/mnt/tests/V7/v7/network
Comment 1 IBM Bug Proxy 2010-08-24 18:40:52 EDT
Created attachment 440789 [details]
network test output
Comment 2 Rob Landry 2010-08-24 21:18:50 EDT
The test appears to fail because no

/etc/sysconfig/network-scripts/ifcfg-sit0 file appears to have been created.
Comment 3 IBM Bug Proxy 2010-08-25 13:02:20 EDT
------- Comment From tpnoonan@us.ibm.com 2010-08-25 12:58 EDT-------
(In reply to comment #4)
> The test appears to fail because no
> /etc/sysconfig/network-scripts/ifcfg-sit0 file appears to have been created.

what should ibm do?
Comment 4 IBM Bug Proxy 2010-08-25 13:11:02 EDT
------- Comment From lnx1138@linux.vnet.ibm.com 2010-08-25 13:08 EDT-------
(In reply to comment #5)
> (In reply to comment #4)
> > The test appears to fail because no
> > /etc/sysconfig/network-scripts/ifcfg-sit0 file appears to have been created.
>
> what should ibm do?

IMO, the tester needs to configure ipv6 to get the sit0 interface
Comment 5 IBM Bug Proxy 2010-09-07 16:01:45 EDT
------- Comment From hienn@us.ibm.com 2010-09-07 15:54 EDT-------
The machine p7 (8233-E8B) has problem to install snap12.  So, I cannot try the suggestion on the machine. However, I tried Red Hat's system-config-network utility on another system, but it doesn't have option to configure sit interfaces.

My question is it is required that network test should include sit0 interface (IPV6 tunnel to IPV4 - that is not default for network) ?
Comment 6 Rob Landry 2010-09-08 13:48:16 EDT
Generally speaking sit0 would not be required testing.  The required testing is for the hardware NIC or the virtual hardware NIC as applicable.  If this in turn requires sit0 or for some reason is itself called sit0 then proper configuration & testing of sit0 would be required.  (The latter case would likely cause other delay for name space collision.)
Comment 7 IBM Bug Proxy 2010-09-17 17:21:47 EDT
------- Comment From hienn@us.ibm.com 2010-09-17 17:17 EDT-------
I reinstalled snap13 and just marked configure network as IUV4. sit0 has not been shown up.
Comment 8 IBM Bug Proxy 2010-09-23 18:30:53 EDT
------- Comment From hienn@us.ibm.com 2010-09-23 18:22 EDT-------
Retested  with RHEL6 RC1 with V7-1.2-25. At beginning, when doing V7 plan, v7 print. sit0 not shown up. But when running network tet. I promped me "do you want to testst0 (y/n). If saying no, it quit the test, sying yes: it adding sit0 interface together with eth0, eth1, and sit0 always fails.
Comment 9 IBM Bug Proxy 2010-09-23 18:40:44 EDT
------- Comment From hienn@us.ibm.com 2010-09-23 18:37 EDT-------
Retested  with RHEL6 RC1 with V7-1.2-25. At beginning, when doing V7 plan, v7 print. sit0 not shown up. But when running network test. It promped me "do you want to test sit0 (y/n). If saying no, it quit the test, saying yes: it adding sit0 interface together with eth0, eth1, and sit0 always fails.
Comment 10 Rob Landry 2010-09-24 13:57:27 EDT
Is there hardware associated with sit0 or just the ipv4/6 tunnel?

The '--disable --device sit0' and/or '--device {not sit0}' should allow for control of which device(s) get tested.

Can we get a copy of the results rpm, including the info and failed network runs?
Comment 11 IBM Bug Proxy 2010-09-27 10:01:38 EDT
------- Comment From lxie@us.ibm.com 2010-09-27 09:57 EDT-------
(In reply to comment #16)
> Is there hardware associated with sit0 or just the ipv4/6 tunnel?
>
> The '--disable --device sit0' and/or '--device {not sit0}' should allow for
> control of which device(s) get tested.
>
> Can we get a copy of the results rpm, including the info and failed network
> runs?

After disabling sit0, network test went fine. Do you still need a copy of the failed network results rpm and etc?
Comment 12 Rob Landry 2010-09-27 11:20:29 EDT
I don't think that should not be needed.  With the confirmation that disabling sit0 works, I think we can add sit* to the list of interfaces to ignore in v7.

Greg does this sound like a reasonable idea?
Comment 13 IBM Bug Proxy 2010-09-27 11:33:40 EDT
------- Comment From hienn@us.ibm.com 2010-09-27 11:23 EDT-------
The problem can be resolved with options --disable --device sit0 when doing network test.
Comment 14 Greg Nichols 2010-09-27 12:39:08 EDT
(In reply to comment #12)
> I don't think that should not be needed.  With the confirmation that disabling
> sit0 works, I think we can add sit* to the list of interfaces to ignore in v7.
> 
> Greg does this sound like a reasonable idea?

Yes.
Comment 15 Rob Landry 2010-11-19 10:55:36 EST
I believe the end result is sit0 should be added to the ignore list for network interfaces.
Comment 18 Greg Nichols 2011-01-26 12:02:17 EST
Created attachment 475442 [details]
network test patch adding "sit" to the list of interfaces to ignore
Comment 20 IBM Bug Proxy 2011-03-26 11:21:52 EDT
------- Comment From lxie@us.ibm.com 2010-09-29 12:33 EDT-------
(In reply to comment #18)
> The problem can be resolved with options --disable --device sit0 when doing
> network test.

change the severity to high as 'disable' sit0 works
Comment 21 Rob Landry 2011-03-28 11:16:50 EDT
Can the test suite beta (v7-1.3-19) be tested to verify this issue is resolved?
Comment 22 IBM Bug Proxy 2011-03-28 11:52:16 EDT
------- Comment From hienn@us.ibm.com 2011-03-28 11:46 EDT-------
Working on the test, will post the results when done.
Comment 25 Caspar Zhang 2011-05-01 04:22:55 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In v7 1.2, a problem has been observed that network test included sit0 interface which is not necessarily required for testing. This issue has been fixed in v7 1.3, now sit0 interface is no longer planned nor executed during network testing.
Comment 26 errata-xmlrpc 2011-05-09 12:15:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html

Note You need to log in before you can comment on or make changes to this bug.