Bug 62705 - up2date suggests installing an older version of a program already installed.
up2date suggests installing an older version of a program already installed.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-04 12:36 EST by Dan Naumov
Modified: 2015-01-07 18:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 12:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Naumov 2002-04-04 12:36:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I have abiword-0.99.3-1 installed as an RPM, yet, up2date suggests installing
abiword-0.7.14. Running up2date -p does not solve the problem. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install abiword-0.99.3-1 (found on AbiWord site).
2. Run up2date -l
	

Actual Results:  up2date suggested installing abiword-0.7.14.

Expected Results:  up2date shouldn't have suggested installing an older version
of a program installed on a system.

Additional info:

[root@localhost root]# up2date -l

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
abiword                                 0.7.14         7                   

[root@localhost root]# rpm -qa | grep abiword
abiword-fonts-0.99.3-1
abiword-0.99.3-1
[root@localhost root]# rpm -qa | grep up2date
up2date-2.7.61-7.x.2
Comment 1 Adrian Likins 2002-04-08 15:26:34 EDT
The abiword packages use different epochs, and the version with the highest
epoch always wins. In this case, our packages have a higher epoch set.
Comment 2 Harvey Stein 2002-04-11 22:43:43 EDT
How is it not a bug that it overwrites a newer package with an older one?
Isn't it a major failure in the utility of up2date that people have to cross
check all the packages to make sure a newer package isn't being stepped on?
Comment 3 Adrian Likins 2002-04-11 22:47:40 EDT
It isnt overwriting a newer package with an older one. The fact that
the package from our server has a higher epoch makes it a newer package.
The package with the highest epoch is always considered newer. This generally
isnt needed since most packages never set an epoch, but in this case, our
abiword package has higher epoch, so it _is_ newer to rpm.

Note You need to log in before you can comment on or make changes to this bug.