Bug 62716 - /etc/profile.d/mc.sh doesn't work with zsh
/etc/profile.d/mc.sh doesn't work with zsh
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
: 62764 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-04 16:15 EST by hjl
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 15:25:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2002-04-04 16:15:47 EST
When both zsh and mc are installed, I got

Last login: Thu Apr  4 12:56:45 from shanghai
mc () {
        mkdir -p $HOME/.mc/tmp 2> /dev/null
        chmod 700 $HOME/.mc/tmp
        MC=$HOME/.mc/tmp/mc-$$ 
        /usr/bin/mc -P "$@" > "$MC"
        cd "`cat $MC`"
        /bin/rm -f "$MC"
        unset MC
}

with zsh as my login shell.
Comment 1 Nalin Dahyabhai 2002-04-05 11:41:51 EST
*** Bug 62764 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2002-04-09 15:24:57 EDT
Was this determined to be a mc or zsh bug, or both?
Comment 3 Havoc Pennington 2002-04-09 15:40:27 EDT
4.5.55-3 building now

Note You need to log in before you can comment on or make changes to this bug.