Bug 627202 - TypeError: argument 1 must be Entity, not None
Summary: TypeError: argument 1 must be Entity, not None
Status: CLOSED DUPLICATE of bug 621915
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:954966cbea403edc6...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-25 11:29 UTC by Karsten Loeft
Modified: 2010-11-11 00:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 13:10:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (898.99 KB, text/plain)
2010-08-25 11:29 UTC, Karsten Loeft
no flags Details
Attached traceback automatically from anaconda. (742.52 KB, text/plain)
2010-11-11 00:54 UTC, graeme roberts
no flags Details

Description Karsten Loeft 2010-08-25 11:29:49 UTC
The following was filed automatically by anaconda:
anaconda 14.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 260, in setUserPassword
    self.admin.setpassUser(user, cryptPassword(password, algo=algo), True)
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 270, in setRootPassword
    self.rootPassword["lock"], algo)
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 277, in write
    self.setRootPassword(algo=self.getPassAlgo())
  File "/usr/lib/python2.7/site-packages/pyanaconda/__init__.py", line 317, in write
    self.users.write(self.rootPath)
  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 300, in writeConfiguration
    anaconda.write()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1174, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1195, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: argument 1 must be Entity, not None

Comment 1 Karsten Loeft 2010-08-25 11:29:59 UTC
Created an attachment (id=440892)
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2010-08-25 13:10:02 UTC

*** This bug has been marked as a duplicate of bug 621915 ***

Comment 3 graeme roberts 2010-11-11 00:54:40 UTC
Created attachment 459596 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.