Bug 62737 - I18N environment not set properly
I18N environment not set properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Aaron Brown
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-04 20:44 EST by Derek Tattersall
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 13:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2002-04-04 20:44:34 EST
Description of Problem: emacs invoked from a KDE konsole, the message : 
Warning: locale not supported by Xlib, locale set to C 
 
 
Version-Release number of selected component (if applicable): 
emacs-21.2-1 
 
How Reproducible: 
Happens on every invokation 
 
 
Steps to Reproduce: 
1. Open a terminal window 
2. type "emacs <return>"  
3.  
 
Actual Results: 
Emacs pops up, but the above message appears in the konsole window. 
 
Expected Results: 
 
 
Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-04-05 01:01:05 EST
What locale is this? This is very unlikely to be an emacs problem, more like a
generic locale setup problem.
Comment 2 Derek Tattersall 2002-04-05 06:04:16 EST
 locale reports: 
[dlt@athlon dlt]$ locale 
LANG=en_US.iso885915 
LC_CTYPE="en_US.iso885915" 
LC_NUMERIC="en_US.iso885915" 
LC_TIME="en_US.iso885915" 
LC_COLLATE="en_US.iso885915" 
LC_MONETARY="en_US.iso885915" 
LC_MESSAGES="en_US.iso885915" 
LC_PAPER="en_US.iso885915" 
LC_NAME="en_US.iso885915" 
LC_ADDRESS="en_US.iso885915" 
LC_TELEPHONE="en_US.iso885915" 
LC_MEASUREMENT="en_US.iso885915" 
LC_IDENTIFICATION="en_US.iso885915" 
LC_ALL= 
[dlt@athlon dlt]$ 
This setup is shortly after an install.  When I reported the bug, the only thing I could 
identify was emacs.  Maybe you can figure out where the real problem is.
Comment 3 Trond Eivind Glomsrxd 2002-04-05 12:56:11 EST
Looks like an invalid locale... did you set it yourself?
Comment 4 Derek Tattersall 2002-04-05 17:34:43 EST
No, this was after a custom install.  On reboot kde comes up and I opend a
Konsole, brought up emacs and noted the message.  It was a pretty default
installation; I chose US English from the initial bootnet language screen, and
then left the later Anaconda language screen at the default.  Your supposition
that ther is a problem with the default install is probably correct.
Comment 5 Jeremy Katz 2002-04-06 00:38:01 EST
Due to anaconda creating a locale that X didn't like to get Euro support... not
worth the pain, so reverted in CVS
Comment 6 Michael Fulbright 2002-04-09 19:02:08 EDT
Confirmed fix.

Note You need to log in before you can comment on or make changes to this bug.