Bug 627626 - Missing some crm_foo
Missing some crm_foo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 10:37 EDT by Bruno Travouillon
Modified: 2016-04-26 11:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: pacemaker-1.1.4-1.el6
Doc Type: Bug Fix
Doc Text:
Due to missing Cluster Resource Manager (CRM) scripts, an attempt to run the crm utility caused the following message to be presented to a user: crm_standby not available, check your installation This update re-includes the "crm_master" in the packemaker package, and adapts the crm utility not to require the "crm_standby" and "crm_failcount" scripts, so that the above error message is no longer displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
DRBD errors (413 bytes, application/octet-stream)
2010-08-26 10:37 EDT, Bruno Travouillon
no flags Details

  None (edit)
Description Bruno Travouillon 2010-08-26 10:37:01 EDT
Created attachment 441232 [details]
DRBD errors

Description of problem:

Some crm_foo script are missing in pacemaker package :
 - crm_standby
 - crm_failcount
 - crm_master

crm command is unusable.
DRBD support is broken (see attached logs)

Version-Release number of selected component (if applicable): pacemaker-1.1.2-5.el6.x86_64


How reproducible:

Install pacemaker-1.1.2-5.el6.x86_64 and run crm

Steps to Reproduce:
1. yum install pacemaker
2. crm
3.
  
Actual results:

crm_standby not available, check your installation

Expected results:

crm(live)#

Additional info:
Comment 2 Andrew Beekhof 2010-08-26 13:24:32 EDT
This was found and fixed after beta2 went out.
The fixed version will appear with GA.

crm no longer uses any of them, and crm_master was restored to the package.

crm_standby and crm_failcount are legacy scripts and wont be included.
Comment 4 Dean Jansa 2011-03-01 16:54:41 EST
Verified in  pacemaker-1.1.4-1.el6.x86_64.rpm
crm run without erroring
Comment 5 Jaromir Hradilek 2011-04-26 10:46:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to missing Cluster Resource Manager (CRM) scripts, an attempt to run the crm utility caused the following message to be presented to a user:

    crm_standby not available, check your installation

This update re-includes the "crm_master" in the packemaker package, and adapts the crm utility not to require the "crm_standby" and "crm_failcount" scripts, so that the above error message is no longer displayed.
Comment 6 errata-xmlrpc 2011-05-19 09:49:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0642.html

Note You need to log in before you can comment on or make changes to this bug.