Bug 62781 - umask ignored when creating files or directories on nfs mounts
umask ignored when creating files or directories on nfs mounts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-05 10:52 EST by Robert Jones
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 07:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Jones 2002-04-05 10:52:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79C-SGI [en] (X11; I; IRIX 6.5 IP32)

Description of problem:
When creating a file or directory on an NFS mounted filesystem, it is always
created with umask 022, rather than the current umask.  This bug was noted in
7.1 as bug 53338, but appears not to have been fixed in 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set umask to any value other than 022
2. create file or directory on NFS mounted filesystem
3. ls -ald <filename>

Actual Results:  lgm10 19% cd /disk5
lgm10 20% df -k .
Filesystem           1k-blocks      Used Available Use% Mounted on
garlon:/disk5        140005560 122239216  10654396  92% /disk5
lgm10 21% umask
22
lgm10 22% touch testfile
lgm10 23% mkdir testdir
lgm10 24% ls -ald test*
drwxr-xr-x    2 rjones   games        4096 Apr  5 07:54 testdir
-rw-r--r--    1 rjones   games           0 Apr  5 07:54 testfile
lgm10 25% umask 000
lgm10 26% umask
0
lgm10 27% touch testfile2
lgm10 29% mkdir testdir2
lgm10 30% ls -ald test*
drwxr-xr-x    2 rjones   games        4096 Apr  5 07:54 testdir
drwxr-xr-x    2 rjones   games        4096 Apr  5 07:54 testdir2
-rw-r--r--    1 rjones   games           0 Apr  5 07:54 testfile
-rw-r--r--    1 rjones   games           0 Apr  5 07:54 testfile2
lgm10 31% 


Expected Results:  The second file and directory should have been created with
umask 000, or 666 for the file, 777 for the directory...

Additional info:
Comment 1 Alan Cox 2002-04-05 11:02:15 EST
Works for me on the current RH beta at least

What Red Hat and what kernel errata version is the NFS server running ?
Comment 2 Robert Jones 2002-04-05 11:08:54 EST
Here you go, please let me know if I can provide more...



Red Hat Linux release 7.2 (Enigma)
Kernel 2.4.9-31smp on an i686
login: rjones
Password:
Last login: Fri Apr  5 07:47:53 from jasmine.wds.disney.com
lgm10 1% uname -a
Linux lgm10 2.4.9-31smp #1 SMP Tue Feb 26 06:55:00 EST 2002 i686 unknown
lgm10 2% rpm -q | grep -i redhat
rpmq: no arguments given for query
lgm10 3% rpm -qa | grep -i redhat
redhat-logos-1.1.3-1
redhat-config-network-0.9.10-2
redhat-release-7.2-1
redhat-config-users-0.9.2-6
lgm10 4%
Comment 3 Robert Jones 2002-04-05 11:10:35 EST
I should also mention that the NFS server is IRIX 6.5.13m, and the filesystems are exported with '32bitclients' set.
Comment 4 Steve Dickson 2004-08-11 07:02:41 EDT
This seems to work on current kernels 

Note You need to log in before you can comment on or make changes to this bug.