Bug 62801 - Unrepeatable kernel BUG
Unrepeatable kernel BUG
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-05 13:36 EST by Mark H Johnson
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:47:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark H Johnson 2002-04-05 13:36:56 EST
Description of Problem:
Rebooted a system after installing BT878 video cards (WinTV). Shortly after the system recognized and configured the new cards
it crashed with the following messages at the end...

kernel BUG at /usr/src/redhat/BUILD/kernel-2.4.18/linux/include/asm/spinlock.h:111!
kernel BUG at /usr/src/redhat/BUILD/kernel-2.4.18/linux/include/asm/smplock.h:62!

Rebooted system again. System recognized and configured cards again, but no crash. Has been running OK since.

Version-Release number of selected component (if applicable):
2.4.18

How Reproducible:
Sorry, don't know how.

Steps to Reproduce:
1. Shutdown system
2. Added three WinTV cards to system
3. Rebooted. Selected CONFIGURE when requested after reboot.

Actual Results:
Soon after last "CONFIGURE", system displayed over a page of stack backtrace messages - the last 20 lines available on request.

Expected Results:
System to reboot as normal.

Additional Information:
Not sure what is relevant from the backtrace. Some of the symbolic names listed were...
 - kmem_find_general_cachep_Rsmp [twice]
 - release_console_sem_Rsmp
 - sys_sigaltstack_Rsmp [twice]
 - __alloc_pages_Rsmp
 - remap_page_range_Rsmp
 - vmtruncate_Rsmp
 - mempage_Rsmp
Let me know if you want me to type it in from my notes (may be slight typo's - could not cut/paste and obviously did not get a complete stack trace).
Comment 1 Arjan van de Ven 2002-04-08 10:37:19 EDT
Weird stuff. A driver bug could cause this easily but I'd expect it to be
reproduceable then ;(
Comment 2 Alan Cox 2003-06-05 13:47:07 EDT
I guess destined by one of lifes little mysteries since no reports were filed of
further occurences.

Closing

Note You need to log in before you can comment on or make changes to this bug.