Bug 62868 - garbage character at end of output - new netgroup feature
Summary: garbage character at end of output - new netgroup feature
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rwall   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-06 20:37 UTC by Jack Perdue
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 18:19:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes garbage by null terminating output - adds "-n netgroup" option (7.07 KB, patch)
2002-04-06 20:38 UTC, Jack Perdue
no flags Details | Diff
a better version of the previous patch with free()'s [so OS doesn't have to] (6.53 KB, patch)
2002-04-06 22:32 UTC, Jack Perdue
no flags Details | Diff

Description Jack Perdue 2002-04-06 20:37:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1

Description of problem:
rwall puts an extra garbage character at the
end of output I believe due to a lack of string
termination.

The patch provided (shortly) fixes that (easy one line fix).
It also adds a "-n netgroup" option to send messages to
all hosts in a netgroup (like on HP-UX).

The patch was submitted to netbug@ftp.uk.linux.org but
I'll also provide it here in case you find it as useful
as I do.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rwall host
2.type message
3. <Ctrl>-<D> for EOF

	

Actual Results:  message comes up on host with garbage as last character

Expected Results:  message comes up on host without garbage

Additional info:

Comment 1 Jack Perdue 2002-04-06 20:38:10 UTC
Created attachment 52546 [details]
fixes garbage by null terminating output - adds "-n netgroup" option

Comment 2 Jack Perdue 2002-04-06 22:32:37 UTC
Created attachment 52547 [details]
a better version of the previous patch with free()'s  [so OS doesn't have to]

Comment 3 Phil Knirsch 2004-08-31 14:36:08 UTC
Looks like a good enhancement.

Will most likely get integrated in one of the next development
packages going out with Fedora.

Read ya, Phil

Comment 4 Phil Knirsch 2004-09-02 18:19:52 UTC
OK, included fixed and adapted patch in rwall-0.17-22 and newer.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.