Bug 62872 - runlevel 5 won't start X without eth0 being activated
runlevel 5 won't start X without eth0 being activated
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-06 16:47 EST by Joshua Jensen
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-06 16:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-04-06 16:47:32 EST
Description of Problem:

Run level 5 fail to bring up X simply because eth0 is not activated.  With my
dhcp'ing host on my switched network, sometime eth0 doesn't get activated at
boot time.  This has happened before with RHL 7.2, without problems.  

The work around is to log in as root, bring up eth0 with the ifup command, then
type:

init 3; sleep 2; init 5

If you think this might be lookback related, my /etc/hosts file has only one
line in it:

127.0.0.1
	localhost.localdomain localhost


Version-Release number of selected component (if applicable):


[joshua@thunderbird joshua]$ rpm -qa | egrep "kernel|XFree|NVIDIA"

kernel-2.4.18-0.13
XFree86-xfs-4.2.0-6.52
XFree86-ISO8859-15-100dpi-fonts-4.2.0-6.52
NVIDIA_kernel-1.0-2802
XFree86-libs-4.2.0-6.52
XFree86-base-fonts-4.2.0-6.52
XFree86-100dpi-fonts-4.2.0-6.52
XFree86-twm-4.2.0-6.52
NVIDIA_GLX-1.0-2802
XFree86-tools-4.2.0-6.52
XFree86-4.2.0-6.52
XFree86-devel-4.2.0-6.52
kernel-source-2.4.18-0.13
XFree86-font-utils-4.2.0-6.52
XFree86-xdm-4.2.0-6.52
Comment 1 Mike A. Harris 2002-04-08 17:28:56 EDT
This sounds to me like network misconfiguration, and not an X bug.
I am able to start X up on my test box with no network interfaces other
than lo up.

Note You need to log in before you can comment on or make changes to this bug.