This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 628980 - authconfig --passalgo option does not work
authconfig --passalgo option does not work
Status: CLOSED DUPLICATE of bug 565521
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-31 11:02 EDT by Peter Vrabec
Modified: 2010-09-01 03:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-01 03:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2010-08-31 11:02:29 EDT
Description of problem:
# /usr/sbin/authconfig --passalgo=sha512 --update
# grep crypt_style /etc/libuser.conf 
  
Actual results:
crypt_style = md5

Expected results:
crypt_style = sha512

Additional info:
# rpm -qf /usr/sbin/authconfig
authconfig-6.1.7-2.fc14.x86_64
Comment 1 Tomas Mraz 2010-09-01 03:40:56 EDT
It would work if you passed --updateall or if you switched to sha256 first and then to sha512. There is a problem with syncing configuration files if some of them already contain the requested value.

*** This bug has been marked as a duplicate of bug 565521 ***

Note You need to log in before you can comment on or make changes to this bug.