Bug 62910 - kernel hangs at partition check hde on HPT366.
kernel hangs at partition check hde on HPT366.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 11:21 EDT by Joshua
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 13:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua 2002-04-07 11:21:52 EDT
Description of Problem:
The hard drive is hde, attached to onboard HPT366 IDE2.
Uprgade or install both fail because the kernel locks up at the point of
"Partition check", hde. This is the same with the kernel installed via up2date
and the boot kernel on the CD.

Version-Release number of selected component (if applicable):
kernel-2.4.18-0.18

How Reproducible:
100% 

Steps to Reproduce:
1. Boot using the install CDROM. 
2. Boot using the kernel installed by up2date after updating skipjack-beta1.
3. 

Actual Results:
Boot process halts at "Partition check: hde:". 

Expected Results:
Installation or system startup. Every other public release since 7.0 has worked
with this system configuration.

Additional Information:

Abit be6 System board.
The results were the same with 2 different hard drives, WD 40G 7200rpm and IBM
40G 7200rpm.
Comment 1 Joshua 2002-04-08 22:28:05 EDT
Swapping hpt366.c with that from the kernel-2.4.18-0.8 source and recompiling
produces a bootable kernel-2.4.18-0.13.
Comment 2 Arjan van de Ven 2002-04-09 05:34:27 EDT
WHen 2.4.18-0.18 hits rawhide (should be real soon now); could you test that ?
It fixes the hpt366 issues here
Comment 3 Chad Remesch 2002-04-09 12:34:46 EDT
2.4.18-0.18smp boots and so far works for me on an Abit BP6 using the HPT366 controller. 
This same system would hang on the "partition check" when I tried 2.4.18-0.16smp. Does 
anyone have an updated boot/install floppy image so I can test this with the Skipjack 
beta 2 ISO's? I ask because I'm currently running 2.4.18-0.18smp on a customized RH7.2 
install since Skipjack beta 2 won't boot. Thanks for the fix.
Comment 4 Arjan van de Ven 2002-04-09 12:39:43 EDT
You could try passing "ide=nodma" on the syslinux prompt; that worked around the
bug for some folks (and you wouldn't need new isos)
Comment 5 Joshua 2002-04-09 13:21:20 EDT
Yes, the RawHide kernel-2.4.18-0.18 works for me.
Skipjack-beta1 -> beta2 update via up2date.
Comment 6 Arjan van de Ven 2002-04-10 07:43:31 EDT
Ok closing as "fixed in rawhide".
Thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.