This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 62914 - 'gdm' option 'Browser=true' crashes 'X'
'gdm' option 'Browser=true' crashes 'X'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 13:08 EDT by Joachim Frieben
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 11:24:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-04-07 13:08:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
Changing the 'Browser' option in 'gdm.conf' from 'false' to 'true' crashes 'X'
at start-up after logging out from the current session.

Version-Release number of selected component (if applicable):
sawfish-1.0.1-7

How reproducible:
Always

Steps to Reproduce:
1. Log in to GNOME session.
2. Set 'Browser=true' in 'gdm.conf'
3. Log out
	

Actual Results:  After several unsuccessful attempts of launching the X server,
the user is dropped to text console login.

Expected Results:  The X server should have started up as expected, and the
graphical login panel of 'gdm' should have appeared with user faces enabled.

Additional info:

Observed on two different machines running 'XFree86*' and 'Xhp*' respectively.
Comment 1 Havoc Pennington 2002-04-09 15:18:18 EDT
works for me - can you give more details - how many users do you have, do some
of them have faces, can you change whether it happens by varying those things?

Or does it happen on any machine with any users, and I'm just not following the
right steps to reproduce the problem?
Comment 2 Joachim Frieben 2002-04-16 09:36:34 EDT
I have simply changed the browser option to 'true' without any further
customization. Adding or removing a 'photo' file to any or some of the users did
not change anything. However, '/var/log/messages' exhibits the following error
messages which were issued while 'gdm' was respawned before the user was finally
dropped back to text console mode:

Apr 16 15:20:37 leibniz init: Switching to runlevel: 5
Apr 16 15:20:37 leibniz autofs: automount startup succeeded
Apr 16 15:20:37 leibniz wine: Registering binary handler for Windows applications
Apr 16 15:20:38 leibniz rc: Starting wine:  succeeded
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory /usr/games/.gnome/gdm
does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/var/gopher/.gnome/gdm does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory /var/ftp/.gnome/gdm
does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/var/lib/rpm/.gnome/gdm does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory /dev/.gnome/gdm does
not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory /etc/ntp/.gnome/gdm
does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory //.gnome/gdm does not
exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/var/lib/nfs/.gnome/gdm does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/var/lib/nfs/.gnome/gdm does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory //.gnome/gdm does not
exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/var/arpwatch/.gnome/gdm does not exist.
Apr 16 15:20:38 leibniz gdm[4325]: run_pictures: Directory
/home/lorene/.gnome/gdm does not exist.

before repeating the whole sequence. The involved accounts happen to be those
tho which nobody has ever logged in. Logically, they hence do not exhibit any
'.gnome' directory which 'gdm' seems to be desperately seeking. I guess that's
the reason why things mess up.
Comment 3 Havoc Pennington 2002-07-05 17:55:04 EDT
Code for this is changed substantially in Rawhide, need to confirm that it still
occurs.
Comment 4 Havoc Pennington 2002-12-19 20:39:25 EST
Please reopen if still happening in 8.0.
Comment 5 Joachim Frieben 2004-04-20 03:06:01 EDT
Bug resolved at least as of Fedora Core 1. No prior version of Red Hat
Linux at my disposal anymore. Thanks!

Note You need to log in before you can comment on or make changes to this bug.