Bug 62919 - 'redhat-config-users' does not create any user account
'redhat-config-users' does not create any user account
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 14:10 EDT by Joachim Frieben
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 03:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-04-07 14:10:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
The attempt to create some user account by means of 'redhat-config-users' does
not have -any- effect, although the whole form displayed after clicking on the
'New User' button had been filled out and the changes accepted by clicking on
the 'Ok' button.

Version-Release number of selected component (if applicable):
1.0-8

How reproducible:
Always

Steps to Reproduce:
1. Log in to root account
2. Launch 'redhat-config-users'
3. Click on 'New User', fill out the form and click on 'Ok'


Actual Results:  No action has been performed! In particular, there is no entry
in '/etc/passwd', no home directory has been created neither. Unfortunately,
there is a long tradition of 'redhat-config-users' being partially broken (have
to exit after creating one single account, change of default shell settings is
not adopted). Apart from this purely functional aspect, the overall graphical
appearance is quite disgusting (icons, fonts) and seems to have  little in
common with the GNOME look that I was used to know and that I liked pretty much
(much better than KDE for instance)!

Expected Results:  A new user account should have been created.

Additional info:

redhat-config-users.py (pid:1925): libglade-WARNING **: unknown property
`child_name' for class `GtkVBox'

redhat-config-users.py (pid:1925): libglade-WARNING **: unknown property
`child_name' for class `GtkNotebook'
/usr/share/redhat-config-users/userWindow.py:67: DeprecationWarning: use
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_pwExpireCheck_toggled'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_filter_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_newUserNameEntry_focus_out_event'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_gidCheckButton_toggled'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_accountExpireCheck_toggled'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_add_group_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_manual_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_ok_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_groupProperties_cancel_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_exit_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_user_clist_select_row'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_cancel_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not findhandler
`on_add_user_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_uidCheckButton_toggled'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_user_clist_button_press_event'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_delete_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_add_group_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_help_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_refreshButton_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_delete_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_add_user_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_userWin_cancel_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_homeDirCheck_toggled'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_groupWin_ok_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_properties_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_properties_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_filterEntry_activate'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_groupWin_cancel_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_groupProperties_ok_button_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_filterButton_clicked'

redhat-config-users.py (pid:1925): ** WARNING **: could not find handler
`on_userWin_ok_button_clicked'
/usr/share/redhat-config-users/userWindow.py:90: DeprecationWarning: use
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userWindow.py", line 246, in
on_userWin_ok_button_clicked
    self.userWinReset()
  File "/usr/share/redhat-config-users/userWindow.py", line 86, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not str
Comment 1 Brent Fox 2002-04-08 10:38:55 EDT
The particular bug you are seeing has been fixed in Rawhide.  Please try
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/redhat-config-users-1.0-10.noarch.rpm

To get rid of most of those GTK warning messages, you should upgrade your pygtk2
packages from Rawhide.

Could you elaborate more on the problem with changing the user's shell?  That
works for me.


As for the appearance, redhat-config-users is using the GTK+ 2 toolkit. 
redhat-config-users uses a library called libuser as the backend, and libuser
needed some features that were only found in glib2, which meant that the
redhat-config-users front-end had to move to Python2 and GTK2.  GTK2 is the
toolkit that GNOME 2 uses, so once GNOME 2 ships with Red Hat Linux, the look
and feel will be similar again.  I have no control over the look of GTK2,
however I think it is an improvement over GTK1.2.  I agree that the icons for
creating new users and groups do not accurately reflect the task.  We have
enlisted the help of some graphic artists to help us address these issues.

As for the fonts, redhat-config-users doesn't do anything about fonts.  It's
pulling in whatever Gnome says the default font is.
Comment 2 Joachim Frieben 2002-04-09 14:06:00 EDT
The shell setting problem is an old one which does not affect recent versions of
'redhat-config-users'.
After upgrading to version '1.0-12' (the one available at the Red Hat site), no
change in sight. The '.xsession-errors' exhibits the following error messages:

/usr/share/redhat-config-users/userWindow.py:66: DeprecationWarning: use
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))
/usr/share/redhat-config-users/userWindow.py:87: DeprecationWarning: use
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userWindow.py", line 277, in
on_userWin_ok_button_clicked
    self.addToUsersGroup(userEnt, userName)
  File "/usr/share/redhat-config-users/userWindow.py", line 305, in addToUsersGroup
    self.userWinReset()
  File "/usr/share/redhat-config-users/userWindow.py", line 83, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not str
/usr/share/redhat-config-users/userWindow.py:66: DeprecationWarning: use
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))
oafd: no process killed
Comment 3 Joachim Frieben 2002-04-09 14:33:40 EDT
Well, I tried different options when creating a user account, and I was able to
finally create it when I left the option of creating its own group checkmarked!
I usually want ordinary users to belong to the 'users' group, so I uncheckmark
the corresponding entry, and exactly this feature seems not to work.
Comment 4 Brent Fox 2002-04-09 17:52:19 EDT
Ok, look for 1.0-13 in Rawhide tomorrow.  I am convinced that this is a GTK2 bug
because of this:

 File "/usr/share/redhat-config-users/userWindow.py", line 83, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not str

A GtkSpinButton should never expect a list...that's just nonsensical.  One of
our PyGtk developers is looking into the problem.  However, I have come up with
a workaround that avoids the problem for now.  Basically, I just call the reset
function at a different point in the code, and it avoids the problem.

Also, I fixed another bug where deleting a user's primary group would strand the
user.  A dialog now appears if you try to delete a user's primary group.

Please try 1.0-13 and verify that things work now.  Thanks a lot for your help
on this.
Comment 5 Brent Fox 2002-04-11 14:55:33 EDT
jfrieben, have you had the chance to test the fix yet?
Comment 6 Joachim Frieben 2002-04-12 03:34:05 EDT
Hi! Yes, version 1.0-13 now works as expected :) Thanks for fixing this bug! I
think it can hence be closed now.
Hopefully, the GTK2 team will do some effort to improve the visual appearance of
the new release. I've been steadily using GNOME since Red Hat Linux 6.0, but I
admit that KDE 3 is really impressive in every respect.
Comment 7 Brent Fox 2002-04-12 10:12:52 EDT
Excellent.  Thanks for working with us on this bug.

Note You need to log in before you can comment on or make changes to this bug.