Bug 62925 - Supplied Arial font is unacceptably ugly
Supplied Arial font is unacceptably ugly
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 16:55 EDT by William Shotts
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 02:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config-4 (3.68 KB, text/plain)
2002-04-08 21:28 EDT, William Shotts
no flags Details
/etc/X11/fs/config (1.10 KB, text/plain)
2002-04-08 21:30 EDT, William Shotts
no flags Details
What it looks like (notice story headlines) (161.17 KB, image/png)
2002-04-08 21:39 EDT, William Shotts
no flags Details
What it should look like (154.12 KB, image/png)
2002-04-08 21:53 EDT, William Shotts
no flags Details

  None (edit)
Description William Shotts 2002-04-07 16:55:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
The Arial font supplied with RHL is poorly crafted and needs to be replaced with
a better one.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat
2.Start X and run mozilla
3.Go to http://www.linuxtoday.com
	

Actual Results:  Rendering of story headline text is very poor.  Similar problem
with www.salon.com. 

Expected Results:  Properly rendered text.

Additional info:

To demonstrate just how bad this is, install the webfonts rpm and notice the
improvement to the text rendering in mozilla and elsewhere.
Comment 1 Mike A. Harris 2002-04-08 13:49:16 EDT
We do not create fonts, we merely ship the existing fonts which are
available.  Please attach a screenshot showing the problem you are seeing.
Also attach your X server config, and a copy of /etc/X11/fs/config also.

Are you using GNOME or KDE, and if KDE, do you have anti-aliased fonts
enabled?
Comment 2 William Shotts 2002-04-08 21:28:59 EDT
Created attachment 52805 [details]
XF86Config-4
Comment 3 William Shotts 2002-04-08 21:30:20 EDT
Created attachment 52806 [details]
/etc/X11/fs/config
Comment 4 William Shotts 2002-04-08 21:39:19 EDT
Created attachment 52807 [details]
What it looks like (notice story headlines)
Comment 5 William Shotts 2002-04-08 21:53:19 EDT
Created attachment 52808 [details]
What it should look like
Comment 6 Alexei Podtelezhnikov 2002-04-08 22:54:11 EDT
Just go ahead and reconfigure mozilla: Edit/Preferences/Appearence/Fonts.
You can even use your own (or microsoft's) fonts. RedHat just stays out of 
licensing trouble. You may not.
Comment 7 Daniel Resare 2002-04-14 02:28:50 EDT
acually microsoft allows individual download of their 'core fonts for the web',
but not redistribution. The installation process can even be automated, see
http://corefonts.sf.net/
Comment 8 Mike A. Harris 2002-05-20 22:23:29 EDT
We are aware of Microsoft's web fonts, and how to automate downloading
them.  That doesn't really have much to do with this particular bug
report though.  Since this appears to be an issue with the particular
font itself, I'm closing the bug as per above.

Please contact the font creators directly if you'd like to arrange to
fund font development.

Note You need to log in before you can comment on or make changes to this bug.