Bug 62927 - gweather does not do anything
gweather does not do anything
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Aaron Brown
:
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-04-07 17:05 EDT by Gene Czarcinski
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 16:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-04-07 17:05:35 EDT
Description of Problem:
Added the Gnome weather applet (gweather) to the panel.

On added a "?" and a small mark to the panel.  Clicking on id mostly did
nothing.  Once it brought up a panel that looked like one to select the weather
site to monitor/display but that panel was frozen.  Had to kill it to get rid of it.

Version-Release number of selected component (if applicable):
fresh install of 7.2.93

How Reproducible:
every time I tried

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	
I also have evolution configured to display weather for a number of cities and
it works fine.
Comment 1 Havoc Pennington 2002-04-09 07:22:44 EDT
output of rpm -q gnome-applets?

gweather is quite fragile, it depends on the specific HTML used for the yahoo
weather site...
Comment 2 Gene Czarcinski 2002-04-09 08:39:18 EDT
This is 7.2.93 (beta4 or skipjack 2).  The version is gnome-applets-1.4.0.5-4
Comment 3 Havoc Pennington 2002-04-09 17:49:11 EDT
Do you have any weird setup like firewall/proxy or something like that?

It seems to work for me.
Comment 4 Gene Czarcinski 2002-04-09 18:47:26 EDT
The system does sit behind a firewall but other "weather" display apps such a
the kweather applet under kde and the evolution weather displays seem to work fine.
Comment 5 Havoc Pennington 2002-04-10 16:47:28 EDT
Maybe you could attach to the applet with strace ("strace -p -f -o output PID")
and then click update, and see what appears in the "output" file?
Comment 6 Gene Czarcinski 2002-04-10 18:50:13 EDT
Well, maybe it wasn't so repeatable after all.  It seems to be working now.  I
am not sure what was happening before but it didn't work.

Now there is about a one second delay and this the display comes up.

However, when it first started, it started with Pittsburg, PA.  I live in
Northern Virginia.  When kweather first starts up, it prompts for the proper site.

Anyway, I am closing this bug since it has started working.
Comment 7 Gene Czarcinski 2002-04-10 18:52:37 EDT
I had another thought about this.

It could have been that the Pittsburg site was down when I tried it.  I tried to
go and configure it but it did not respond.  That may be a real bug and I will
keep an eye on it.
Comment 8 Gene Czarcinski 2002-04-10 19:00:18 EDT
OK, I am reopening this because I was able to reproduce this.  I will try to get
more info but from the description below you may be able to see some fix.

The "problem" is that when the select (Pittsburg by default) site is down or
does not respond (a question mark is displayed), the applet hangs waiting for
something and cannot bring up the properties panel so that it can be reconfigured.
Comment 9 Gene Czarcinski 2002-04-10 19:24:05 EDT
I thought I might be able hang it if I disabled the network interface and that
did not work.  It came up with a question mark but I was able to bring up
properties.  It must be the noaa site itself that won't respond.

I did find one other little unrelated bug with I will bugzilla.
Comment 10 Havoc Pennington 2002-07-03 11:29:08 EDT
In rawhide it doesn't seem to hang on a bad server.

Note You need to log in before you can comment on or make changes to this bug.