Bug 62934 - "command not found" messages
"command not found" messages
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: basesystem (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 20:41 EDT by Gerry Tool
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 09:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mailing-list interchange with Bill Crawford about this problem (4.89 KB, text/plain)
2002-04-08 11:46 EDT, Gerry Tool
no flags Details
Output from revised Bill Crawford command (549 bytes, text/plain)
2002-04-08 12:22 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2002-04-07 20:41:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
I have a fresh install of skipjack beta 2 which seems to be functioning
fine.  However, on boot and shutdown, I get a _lot_ of messages like

"/etc/rc5.d/XXXXXXX: : command not found"

or 

"/etc/rc.d/XXXXXXX: : command not found"

where XXXXXXX is some command name found in /etc/rc.d (these are all
simlinks to /etc/init.d/ where the real commands with common names
reside.

If I grep in the /var/log files, the only ones that appear there are

sshd: /etc/rc5.d/S55sshd: ^Y: command not found
wine: /etc/rc5.d/S98wine: ^Y: command not found

Note the ^Y in the log file.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot or shutdown skipjack beta 2
2.observe screen messages on startup/shutdown
3.
	

Actual Results:  I get a _lot_ of messages like

"/etc/rc5.d/XXXXXXX: : command not found"

or 

"/etc/rc.d/XXXXXXX: : command not found"

where XXXXXXX is some command name found in /etc/rc.d (these are all
simlinks to /etc/init.d/ where the real commands with common names
reside.

If I grep in the /var/log files, the only ones that appear there are

sshd: /etc/rc5.d/S55sshd: ^Y: command not found
wine: /etc/rc5.d/S98wine: ^Y: command not found

Note the ^Y in the log file.

Expected Results:  Normal startup/shutdown without these messages.

Additional info:

Installation appears to be fully functional except for some bugs already
reported or some I haven't found yet.

Probably related; every time I open a shell, the following line appears
before the first command prompt:

bash: : command not found
Comment 1 Gerry Tool 2002-04-08 11:46:22 EDT
Created attachment 52666 [details]
mailing-list interchange with Bill Crawford about this problem
Comment 2 Gerry Tool 2002-04-08 12:22:51 EDT
Created attachment 52684 [details]
Output from revised Bill Crawford command
Comment 3 Bill Nottingham 2002-04-09 01:26:41 EDT
Do you have bash-completions installed?

What locale are you running in?
Comment 4 Gerry Tool 2002-04-09 09:39:42 EDT
We can probably lay this one to rest.  I just reinstalled, and the 
messages are not there.  If they return, I'll try to note what might have 
initiated them and post again. 
 
Thanks for all of your troubleshooting effort. 
 
Gerry 
Comment 5 Bill Nottingham 2002-04-09 11:23:48 EDT
OK

Note You need to log in before you can comment on or make changes to this bug.