Bug 62961 - duplicate entries after upgrade
duplicate entries after upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-08 10:33 EDT by Gene Czarcinski
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 15:19:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-04-08 10:33:58 EDT
Description of Problem:
After performing a 7.2->7.2.93 upgrade, there are duplicate entries in the
nautilus "Start-here" display.  This does not occur after a fresh install.

Version-Release number of selected component (if applicable):
7.2->7.2.93 plus xinetd-2.3.4-0.8 (from rawhide) to fig bugzilla problem 59523

How Reproducible:
every time

Steps to Reproduce:
1. see above
2. 
3. 

Actual Results:
two entries for each type (Favorites 1.7K, Favorties 849 bytes, Preferences
1.4K, Preferences 967 bytes, Program 1.3K, Program 1.0K, Server configuration
2.1K Server Configuration 1.5K, System Settings 1.8K, System Settings 1.5K)

Expected Results:
one entry for each type (Favorites, Preferences, Program, Server configuration,
System Settings)


Additional Information:
	
The stuff on the next level down appears to be the same for a pair but I did not
check it item by item.
Comment 1 Havoc Pennington 2002-04-10 12:28:30 EDT
the dups are probably rpmsave/rpmnew files since things were mistakenly marked
as %config, I think
Comment 2 Gene Czarcinski 2002-04-10 12:58:46 EDT
You are probably correct.  Do you know where these things are stored and I can
verify it.
Comment 3 Havoc Pennington 2002-04-10 14:12:01 EDT
Should be in /etc/X11/starthere
Comment 4 Gene Czarcinski 2002-04-10 14:24:44 EDT
Yup.  It was "rpmsave" files.  Two files for each .. one named <>.desktop and
the other <>.desktop.rpmsave.  Deleting the rpmsave files got me back to one
when I started starthere.

But, how is this going to be fixed in the final (change the rpm to make them non
config files)?
Comment 5 Gene Czarcinski 2002-04-10 14:26:35 EDT
I knew I had another question:  Why did starthere pick up the rpmsave files? 
Why didn't it just use the <>.desktop files?

Isn't this a bug in starthere?
Comment 6 Havoc Pennington 2002-04-10 14:53:49 EDT
start-here isn't anything special, it's just a regular file manager window. So
it displays all the files.

I'm not sure yet if we'll remove the %config, or hack gnome-vfs to filter out
the .rpmsave files.
Comment 7 Gene Czarcinski 2002-04-10 15:19:31 EDT
If it displays all files in the directory, then why both with <>.desktop instead
of just <>.

If it is looking only for desktop files then why pick up the rpmsave files?
Comment 8 Havoc Pennington 2002-04-11 12:59:15 EDT
gnome-vfs-1.0.5-3 should filter out the rpmsave files.

Note You need to log in before you can comment on or make changes to this bug.