Bug 62964 - RFE: move share libs to WindowMaker package
RFE: move share libs to WindowMaker package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 11:26 EDT by Gene Czarcinski
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 13:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for spec file (963 bytes, patch)
2002-04-09 13:30 EDT, Gene Czarcinski
no flags Details | Diff
patched (updated) spec file (7.84 KB, text/plain)
2002-04-09 13:31 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2002-04-08 11:26:16 EDT
This was originally a bug asking for splitting WindowMaker-libs into two
packages (bugzilla 14050 which was deferred but never followed up on).

The are two SHARED libraries in WindowMaker-libs -- libdockapp and libwraster
which are NOT development but instead are needed to support runtime WindowMaker.

I suggest moving these two libraries from the WindowMaker-libs package to the
WindowMaker package (should be just a spec file change since both are built from
the WindowMaker src package).

This would also make WindowMaker-libs a true "Development/Libraries" package
since that is the "Group" designation.

If this cannot make it into the current round, please queue it up for the next
round.
Comment 1 Gene Czarcinski 2002-04-09 13:05:11 EDT
I have taken a look at the src.rpm and the spec file and it does not look that
difficult to fix this problem.  I you want, I can work up a patch for the spec file.
Comment 2 Gene Czarcinski 2002-04-09 13:30:13 EDT
Created attachment 52887 [details]
patch for spec file
Comment 3 Gene Czarcinski 2002-04-09 13:31:01 EDT
Created attachment 52888 [details]
patched (updated) spec file
Comment 4 Phil Copeland 2002-04-15 17:44:53 EDT
Beware of specspo,..
specspo handles translations but also happens to pull in the definitions for
Groups
Although I've changed it in teh windowmaker spec file specso has the final say.
In theory it's now sorted out

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.