Bug 629727 - early alpha release of 389-ds in official repos
early alpha release of 389-ds in official repos
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: 389-ds (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-02 15:49 EDT by Brian LaMere
Modified: 2013-01-10 01:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 16:00:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian LaMere 2010-09-02 15:49:45 EDT
Description of problem:

If someone does a "yum install 389-ds" right now, they will get a release that according to richm (of 389-ds) "was an early alpha version that was only in testing and should not have been pushed to stable (not sure how that happened)" (post on 389-users).

Version-Release number of selected component (if applicable):

I've been made aware that the "a1" indicates that it is the first alpha.  Within the 389 tools, the following "a1" packages are in the current repos.

389-ds-base-1.2.6-0.1.a1.fc13
389-ds-base-selinux-1.2.6-0.1.a1.fc13
389-admin-1.1.11-0.1.a1.fc13
389-admin-selinux-1.1.11-0.1.a1.fc13

I recommend retagging or removing these packages, so that people who go to install 389 Directory Server won't have problems.  I have 3 bug reports for issues I'm experiencing, which all may be because of the early-alpha code that shouldn't be in use.

How reproducible:

100%  (type "yum install 389-ds" and see what gets installed)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2010-09-02 15:56:07 EDT
We do not remove packages from the released Everything tree. Assigning to 389-ds... they're planning on pushing a newer build, as I recall.
Comment 2 Rich Megginson 2010-09-02 16:00:44 EDT
I'm not sure what happened here - perhaps since 389-ds-base-1.2.6.a1 was in rawhide, it just automatically got included into F-13 at the time.

Yes, the official final RTM version of 389-ds-base-1.2.6-1 is due to hit Stable any day now.
Comment 3 Brian LaMere 2010-09-02 16:29:00 EDT
since I have 3 bugs that might be because of the a1 code, and since I am using 389-ds in production (at a1) and am currently moving lots and lots of info in to it...is it possible to get an idea when "any day now" might be so I can schedule maintenance in advance for as soon after that as possible?

Alternatively, if it is more likely to be 10-20 days instead of 1-4 days, should I consider moving to the latest RC for 1.2.6-1, or perhaps just going backward to an earlier version?  I'm concerned about what bugs I may not have noticed yet, or data corruption of my directory caused by something in the a1 release I'm on.
Comment 4 Rich Megginson 2010-09-02 16:41:15 EDT
(In reply to comment #3)
> since I have 3 bugs that might be because of the a1 code, and since I am using
> 389-ds in production (at a1) and am currently moving lots and lots of info in
> to it...is it possible to get an idea when "any day now" might be so I can
> schedule maintenance in advance for as soon after that as possible?
> 
> Alternatively, if it is more likely to be 10-20 days instead of 1-4 days,
> should I consider moving to the latest RC for 1.2.6-1, or perhaps just going
> backward to an earlier version?  I'm concerned about what bugs I may not have
> noticed yet, or data corruption of my directory caused by something in the a1
> release I'm on.

Tomorrow, it will have been 7 days since I pushed 389-ds-base-1.2.6-1 to the Testing repos.  At that time, as per Fedora policy, I will be able to request moving the package from Testing to Stable.  Once I do that, it will take another 4-5 days for the package to be signed by Fedora Release Engineering, pushed to the Stable repo, and pushed to all of the mirrors.  At that point, it will be Live.

Note You need to log in before you can comment on or make changes to this bug.