Bug 62999 - source rpm test failure -- run-func
source rpm test failure -- run-func
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 19:56 EDT by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 19:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-04-08 19:56:55 EDT
Description of Problem:
The following output results from running the src.rpm's built-in test:
  run-func
  warning: if you have exported functions defined in your environment,
  warning: they may show up as diff output.
  warning: if so, please do not consider this a test failure
  29,39d28
  < declare -fx mc
  < declare -fx mc ()
  < {
  <     mkdir -p $HOME/.mc/tmp 2>/dev/null;
  <     chmod 700 $HOME/.mc/tmp;
  <     MC=$HOME/.mc/tmp/mc-$$;
  <     /usr/bin/mc -P "$@" >"$MC";
  <     cd "`cat $MC`";
  <     /bin/rm -f "$MC";
  <     unset MC
  < }

Version-Release number of selected component (if applicable):
bash-2.05a-12

How Reproducible:
100%

Steps to Reproduce:
1. install source
2. run tests as per directions in depends testplan
3. notice diff output (above) 

Expected Results:
no diff output.
7.2:bash-2.05-8 produces no output for this test.
Comment 1 Bill Nottingham 2002-04-09 18:35:09 EDT
See the three lines:
warning: if you have exported functions defined in your environment,
warning: they may show up as diff output.
warning: if so, please do not consider this a test failure

Hence, I don't believe this is a test failure.
Comment 2 Ben Levenson 2002-04-10 11:09:20 EDT
I noticed that, but still thought it was suspect since the output was clean
on my 7.2 test box. thanks.

Note You need to log in before you can comment on or make changes to this bug.