Bug 63013 - Installer cannot upgrade existing installation
Installer cannot upgrade existing installation
Status: CLOSED RAWHIDE
Product: Stronghold Cross Platform
Classification: Retired
Component: catapult (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Stronghold Engineering List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-09 05:09 EDT by Joe Orton
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 05:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2002-04-09 05:09:59 EDT
The current (post-beta) installer binary cannot be run on an existing
installation, since it attempts to open var/log/install.log O_EXCL | O_CREAT to
prevent /tmp races.

Fix is to try O_EXCL | O_CREAT then fall back on no-O_CREAT, which still avoids
the /tmp race.
Comment 1 Joe Orton 2002-04-09 05:13:41 EDT
Scratch previous comment.

Solution is really to create the install log in a non-world-writable location,
and not bother with O_EXCL at all.
Comment 2 Joe Orton 2002-04-09 06:08:55 EDT
Fixed in rev 1.117 of catapult/installer/main.c

Note You need to log in before you can comment on or make changes to this bug.