Bug 63037 - X fails after install
X fails after install
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-09 11:30 EDT by Henrik Karlsson
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 13:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile from XFree86 (9.74 KB, text/plain)
2002-04-09 11:33 EDT, Henrik Karlsson
no flags Details
Kickstart file created by anaconda with the autodetected hardware (1.91 KB, text/plain)
2002-04-09 11:35 EDT, Henrik Karlsson
no flags Details
The XF86Config file generated by anaconda (3.68 KB, text/plain)
2002-04-10 05:09 EDT, Henrik Karlsson
no flags Details

  None (edit)
Description Henrik Karlsson 2002-04-09 11:30:16 EDT
Description of Problem:
X fails to start after install on a Dell OptiPlex Gn+ with with a "S3 Trio 
64V2/DX or /GX" graphics card.

Version-Release number of selected component (if applicable):


How Reproducible:
Every install

Steps to Reproduce:
1. Install RedHat skipjack2
2. reboot
3. 

Actual Results:
"INIT: Id "x" respawning too fast: disabled for 5 minutes"

Expected Results:
A nice *dm login screen

Additional Information:
Comment 1 Henrik Karlsson 2002-04-09 11:33:57 EDT
Created attachment 52864 [details]
Logfile from XFree86
Comment 2 Henrik Karlsson 2002-04-09 11:35:42 EDT
Created attachment 52865 [details]
Kickstart file created by anaconda with the autodetected hardware
Comment 3 Michael Fulbright 2002-04-09 12:45:21 EDT
Could you please attach the XF86Config-4 file as well?
Comment 4 Henrik Karlsson 2002-04-10 05:09:07 EDT
Created attachment 53047 [details]
The XF86Config file generated by anaconda
Comment 5 Michael Fulbright 2002-04-10 16:33:49 EDT
This appears to be a X driver bug.
Comment 6 Mike A. Harris 2002-04-11 12:17:29 EDT
XFree86 4.2.0 does not support this card yet.  The Cards entry specified
the XFree86 4 "s3" driver, however it also lists "UNSUPPORTED" which should
force this to use the 3.3.6 server by default.

So, there are two possibilities I can think of:

1) XFree86 4.x was forced during install, in which case this is not a bug,
   because it is unsupported.

2) If anaconda did indeed configure this card to default to 4.x, then
   it is a bug in anaconda or Xconfigurator dependign on which was used
   during install.

Comment 7 Henrik Karlsson 2002-04-11 13:36:48 EDT
I don't remember that i used force to install XFree86 4.x. I can reinstall the
machine next week if it is needed.
Comment 8 Mike A. Harris 2002-04-13 07:46:06 EDT
The current releases of Xconfigurator, anaconda, hwdata should default
this card to using XFree86 3.3.6.  Jeremy Katz tested and confirmed this.

Note You need to log in before you can comment on or make changes to this bug.