Bug 63060 - kde sound stops working
kde sound stops working
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: arts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: 61901 67218 79579
  Show dependency treegraph
 
Reported: 2002-04-09 14:29 EDT by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-04 18:55:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-04-09 14:29:14 EDT
Description of Problem:
I have sound enabled and am running kde.  Sound works at first and then after
some variable time it suddenly stops.  Logoff and then log back in and sound
works again

Version-Release number of selected component (if applicable):
beta4, arts-1.0.0-1

How Reproducible:
Difficult but it has happened at least three times now.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
sound stops, error messages in .xsession-errors

Expected Results:
works

Additional Information:
	
artsd is running both before and after the stopage.  I found messages similar to
the following in ~/.xsession-errors (I was playing kpoker when sound stopped):

Audio File Library: could not open file '/usr/share/sounds/KDE_Beep_Beep.wav'
[error 3]
Audio File Library: could not open file '/usr/share/sounds/KDE_Beep_Beep.wav'
[error 3]
Audio File Library: could not open file
'/usr/share/apps/kpoker/sounds/cardflip.wav' [error 3]
Audio File Library: could not open file
'/usr/share/apps/kpoker/sounds/cardflip.wav' [error 3]
Audio File Library: could not open file
'/usr/share/apps/kpoker/sounds/cardflip.wav' [error 3]
Audio File Library: could not open file '/usr/share/apps/kpoker/sounds/lose.wav'
[error 3]

While it was kpoker this time, other times it was not.
Comment 1 Gene Czarcinski 2002-04-09 16:40:51 EDT
OK, it happened again and again playing kpoker.  I am going to let this system
just sit as it is for now in the hopes that you might want me to look at something,
Comment 2 Bernhard Rosenkraenzer 2002-04-10 06:04:06 EDT
I can't reproduce this... Are you running any other applications? What soundcard are you 
using?
Comment 3 Gene Czarcinski 2002-04-10 06:23:57 EDT
I figured this was not realy reproducable or others would have problems.

The sound card is Ensoniq 5880 AudioPCI (Rev 02) supported by the es1371 module.

Whats running: kde plus usual stuff and 4 konsole windows, minimized mozilla,
kpoker.  The system is still in the state where sound quit and I can poke around
whereever you suggest.
Comment 4 Gene Czarcinski 2002-04-10 07:29:30 EDT
I just noticed some messages in /var/log/messages which seem to be timestamped
about the time sound stopped:

Apr  9 14:12:40 moscow modprobe: modprobe: Can't locate module sound-slot-1
Apr  9 14:12:40 moscow modprobe: modprobe: Can't locate module sound-service-1-0
Apr  9 14:12:40 moscow modprobe: modprobe: Can't locate module sound-slot-1
Apr  9 14:12:40 moscow modprobe: modprobe: Can't locate module sound-service-1-0
Apr  9 14:12:57 moscow modprobe: modprobe: Can't locate module sound-slot-1
Apr  9 14:12:57 moscow modprobe: modprobe: Can't locate module sound-service-1-0
Apr  9 14:12:57 moscow modprobe: modprobe: Can't locate module sound-slot-1
Apr  9 14:12:57 moscow modprobe: modprobe: Can't locate module sound-service-1-0
Comment 5 Bernhard Rosenkraenzer 2002-04-10 10:07:09 EDT
Does sound work once again if you kill artsd? 
This might be a duplicate of bug 62898
Comment 6 Gene Czarcinski 2002-04-10 11:13:50 EDT
I have not tried just killing artsd since I was not sure how to properly start
it again.  However, I know that loging out and then back in does cure the problem.
Comment 7 Gene Czarcinski 2002-04-10 11:18:09 EDT
I took a look at 62898 again and I had look at that one before submitting this
one.  While it may end up with being the same problem, it seems different since
sound does work "for a while" and then dies.  Logging out and back in gets sound
working again.  The way I read 62898, sound never works (I wonder if it works
for gnome on that system).
Comment 8 Bernhard Rosenkraenzer 2002-08-12 09:12:06 EDT
I still can't reproduce this. 
Anyone else? 
Comment 9 Harald Hoyer 2002-08-12 09:16:19 EDT
if you log in as another user (e.g. root) maybe you loose ownership of /dev/dsp??
Comment 10 Ngo Than 2003-02-04 18:55:50 EST
i close it because we cannot reproduce this bug. Please reopen it if it's still
there.

Note You need to log in before you can comment on or make changes to this bug.