Bug 63091 - RFE: cdrom kickstart install won't use nfs
Summary: RFE: cdrom kickstart install won't use nfs
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 22:55 UTC by Alexandre Oliva
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 22:55:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-04-09 22:55:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
The `nfs' line in the ks.cfg appears to be ignored when booting from the install
CD-ROM.  I wish I could use it to start network installs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a ks.cfg with an `nfs' line pointing to an nfs server holding the
installation tree, from which you've successfully done a kickstart install
starting with the bootnet floppy disk before
2.Boot the installation CD-ROM with ks=floppy

	

Actual Results:  It loads the network card driver successfully, but it will
install from the CD.

Expected Results:  I expected it to install from the NFS tree, so that I didn't
have to go swapping CDs every now and then.

Additional info:

Comment 1 Jeremy Katz 2002-04-10 04:36:57 UTC
This actually works, but only if the module is one of the ones which is on the
CD.    The only "standard" network card drivers on the CD are eepro100 and 3c59x
because they're use for PCMCIA (and we use the pcmcia modules + local modules
for the cdboot).  Unfortunately, not really enough room to add the rest of the
network modules from bootnet.

Comment 2 Alexandre Oliva 2002-04-10 05:16:54 UTC
Any chance of having the drivers disk as a separate session in the CD (would it
be mountable as such?), or of mounting the drivers img file from the CD itself
using a loopback device?


Note You need to log in before you can comment on or make changes to this bug.