Bug 63094 - Upgrading to perl-5.6.1 breaks cleanfeed filter_innd.pl
Summary: Upgrading to perl-5.6.1 breaks cleanfeed filter_innd.pl
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cleanfeed (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 23:31 UTC by James Antill
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 23:31:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Antill 2002-04-09 23:31:10 UTC
Description of Problem:
 In perl 5.6.1 perl will error if you try to alter a read-only variable with tr
even if the text is the same as the source (Ie. "123" =~ tr/1/1/; is now an
error/exception). However this was (and still is) documented as a way to count
the number of characters of type X and cleanfeed (filter_innd.pl) uses this
idiom with a read-only variable on line 572.

Additional Information:

 Here is how I fixed cleanfeed...
	
{ my $tmp = $hdr{'__BODY__'};
        $lines = $tmp =~ tr/\n/\n/; }
# The tr doesn't work because __BODY__ is readonly
# $lines = $hdr{'__BODY__'} =~ tr/\n/\n/;

Comment 1 Florian La Roche 2002-04-15 19:56:55 UTC
This is already fixed in the current rpm.

Thanks,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.