Bug 63117 - startx bogus test for hostname version
startx bogus test for hostname version
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 61278 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-10 04:40 EDT by diego.santacruz
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 18:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 2002-04-10 04:40:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
The /usr/X11R6/bin/startx has an erroneous test for the version of the hostname
executable. The test captures only stdout, while it should capture stderr as well.

Version-Release number of selected component (if applicable):

XFree86-4.2.0-6.52

How reproducible:
Always

Steps to Reproduce:
1. Type startx at the console
2.
3.
	

Actual Results:  Typing startx prints garbage to stderr:

net-tools 1.60
hostname 1.100 (2001-04-14)

Expected Results:  No garbage printed

Additional info:

The solution is to replace the line

        if [ -z "`hostname --version | grep GNU`" ]; then

with

        if [ -z "`hostname --version 2>&1 | grep GNU`" ]; then
Comment 1 Bill Nottingham 2002-04-10 18:25:54 EDT
*** Bug 61278 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2002-04-11 12:33:34 EDT
Fixed in rawhide XFree86 4.2.0-6.63 and later.

Note You need to log in before you can comment on or make changes to this bug.