Bug 63153 - WorkDir: in /etc/mrtg/mrtg.cfg
WorkDir: in /etc/mrtg/mrtg.cfg
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: mrtg (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-04-10 14:02 EDT by gman
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 16:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gman 2002-04-10 14:02:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The default WorkDir in /etc/mrtg/mrtg.cfg is set to /home/httpd/html/mrtg, 
which doesn't exist. 'mrtg' doesn't complain when you execute via a shell, but 
when you execute it via cron job you get an error saying that directory doesn't 
exist.

If you comment out WorkDir for that file, then it complains that you need a 
WorkDir statement..

You might want to change that to /var/www/html/mrtg which does exist and is 
part of that package ..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create cfg for device
2. set cronjob to run mrtg
3. check email for errors..
	

Additional info:
Comment 1 Nalin Dahyabhai 2002-04-11 11:43:29 EDT
Is this happening after upgrading from a previous version, or when just
installing the current version (2.9.17-3)?  I ask because the mrtg.cfg from
2.9.17-3 already has the correct setting in it.

The mrtg.cfg configuration file is marked %config(noreplace), so when an upgrade
is performed, the correct settings should at least be in /etc/mrtg/mrtg.cfg.rpmnew.
Comment 2 gman 2002-06-21 16:24:39 EDT
looks like that was exactly the problem. this was an upgrade..
Comment 3 Nalin Dahyabhai 2002-07-23 14:03:38 EDT
Alright then, closing as fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.