Bug 63166 - up2date rpm reports a seemingly unrelated error regarding snmp
up2date rpm reports a seemingly unrelated error regarding snmp
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-10 15:37 EDT by Kambiz Aghaiepour
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 15:37:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kambiz Aghaiepour 2002-04-10 15:37:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.18-0.7 i686)

Description of problem:
[root@db1 root]# up2date rpm

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package ucd-snmp-4.2.3-5 (which is newer than ucd-snmp-4.2.3-1.7.2.3) is already
installed


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login to db1.webqa-colo.redhat.com
2. run: up2date rpm

	

Actual Results:  It doesn't work.


Expected Results:  It should work.


Additional info:

ucd-snmp was snarfed from 7.3 tree and rebuilt due to bugs in the errata release
and core dumping if disk section is used.
Comment 1 Adrian Likins 2002-04-10 15:44:01 EDT
sounds like the ucd-snmp you have is linked against the
old rpm, and when it tries to update your ucd-snmp to the
one built against the newest errata rpm, it cant because
your local version of ucd-snmp is newer than the available
one linked against the new rpm. 

Basically, thats what it's supposed to do. It's an unsolveable
dep set at that point. I suspect the error message could be
more explicilty, but then, when isnt that the case.

Note You need to log in before you can comment on or make changes to this bug.