Bug 63190 - configureX kickstart won't accept 1920x1440
Summary: configureX kickstart won't accept 1920x1440
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: skipjack-beta2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-04-10 22:31 UTC by Alexandre Oliva
Modified: 2010-09-21 18:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 23:44:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-04-10 22:31:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Get a machine with a video card and monitor that can go up to 1920x1440 (say,
a RIVA TNT2 card with a Philips 107P monitor).

2.Create a ks.cfg file with the line:

xconfig --card "RIVA TNT2" --videoram 32768 --hsync 30-92 --vsync 50-160 --depth
16 --resolution 1920x1440 --defaultdesktop=GNOME --startxonboot

3.Boot off the CD installation media for a kickstart install

Actual Results:  installclass.py, line 384, in configureX, raises a
RuntimeError: `Selected resolution and bitdepth not possible with video ram
detected.  Perhaps you have to specify video ram'

Expected Results:  32MB is surely enough for 1920x1440x16, and this actually
works if I change the resolution to 1600x1200 in the kickstart file, then add
`1920x1440' as a video mode to XF86Config-4 after installation.

Additional info:

There's also the problem that the installer goes back to text mode and prints a
back trace, instead of a user-friendly error message, and that the error message
itself is misleading, because I have specified the amount of videoram.

Comment 1 Jeremy Katz 2002-04-10 22:53:28 UTC
Added

Comment 2 Michael Fulbright 2002-04-15 23:44:12 UTC
Confirmed fixed.


Note You need to log in before you can comment on or make changes to this bug.