Bug 63219 - Installer crashed at Test Setting for sis630 video card
Installer crashed at Test Setting for sis630 video card
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-11 06:55 EDT by alan.vickers
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan.vickers 2002-04-11 06:55:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Installation of 7.2 crashed at Customize Graphics Configuration, when Test 
Setting was 

pressed.

--------------------------------------------------------------------------------
-----
An unhandled exception has occurred. This is most likely a bug. Please copy the 
full text of 

this exception or save the crash dump to a floppy then file a detailed bug 
report against 

anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (innermost last)
 File "/usr/bin/anaconda", line 620 in ?
 File "/usr/lib/anaconda/gui.py", line 350 in run
 File "/usr/lib/anaconda/gui.py", line 778 in run
 File "/usr/lib/python1.5/site-packages/gtk.py", line 2608 in mainloop
 File "/usr/lib/python1.5/site-packages/gtk.py", line 125 in __call__
 File "/usr/lib/anaconda/iw/xconfig_gui.py", line 63 in testPressed
 File "/usr/lib/anaconda/xf86config.py", line 1012 in test
OSError:[Errno 2] No such file or directory
--------------------------------------------------------------------------------
-----

Previous installs without doing Test Setting appeared to go ok, but following 
error occurred 

when doing startx:
------------------------------------------------
execve failed for /etc/X11/X (errno 2)
giving up
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3) Server error
----------------------------------------------

Also fails when trying to run Xconfigurator, get Welcome screen & PCI probe:
-------------------------------------------------
PCI probing found a:
PCI Entry   : Silicon Integrated Systems [SiS]|SiS630
X Server    : XF86_SVGA
XFree4 driver : (default)
-------------------------------------------------
then crashes with message:
-------------------------------------------------
Server doesn't exist, can't continue.
tried to use ../../usr/X11R6/XF86_SVGA
-------------------------------------------------
(there are no drivers in that directory)


Problem probably related to SiS630 video innterface.
Note 7.2 finds it during install
7.1 doesn't find it during install, but can run Xconfigurator & startx ok under 
7.1


A work around seems to be to copy a 7.1 version of XF86_SVGA to /usr/X11R6/bin




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 7.2
2.at Customize Graphics Configuration
3.press Test Settings
	

Actual Results:  Crashed

Expected Results:  Continued installlation

Additional info:

Installation of 7.2 crashed at Customize Graphics Configuration, when Test 
Setting was 

pressed.

--------------------------------------------------------------------------------
-----
An unhandled exception has occurred. This is most likely a bug. Please copy the 
full text of 

this exception or save the crash dump to a floppy then file a detailed bug 
report against 

anacondaat http://bugzilla.redhat.com/bugzilla/

Traceback (innermost last)
 File "/usr/bin/anaconda", line 620 in ?
 File "/usr/lib/anaconda/gui.py", line 350 in run
 File "/usr/lib/anaconda/gui.py", line 778 in run
 File "/usr/lib/python1.5/site-packages/gtk.py", line 2608 in mainloop
 File "/usr/lib/python1.5/site-packages/gtk.py", line 125 in __call__
 File "/usr/lib/anaconda/iw/xconfig_gui.py", line 63 in testPressed
 File "/usr/lib/anaconda/xf86config.py", line 1012 in test
OSError:[Errno 2] No such file or directory
--------------------------------------------------------------------------------
-----

Previous installs without doing Test Setting appeared to go ok, but following 
error occurred 

when doing startx:
------------------------------------------------
execve failed for /etc/X11/X (errno 2)
giving up
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3) Server error
----------------------------------------------

Also fails when trying to run Xconfigurator, get Welcome screen & PCI probe:
-------------------------------------------------
PCI probing found a:
PCI Entry   : Silicon Integrated Systems [SiS]|SiS630
X Server    : XF86_SVGA
XFree4 driver : (default)
-------------------------------------------------
then crashes with message:
-------------------------------------------------
Server doesn't exist, can't continue.
tried to use ../../usr/X11R6/XF86_SVGA
-------------------------------------------------
(there are no drivers in that directory)


Problem probably related to SiS630 video innterface.
Note 7.2 finds it during install
7.1 doesn't find it during install, but can run Xconfigurator & startx ok under 
7.1


A work around seems to be to copy a 7.1 version of XF86_SVGA to /usr/X11R6/bin
Comment 1 Michael Fulbright 2002-04-11 14:17:42 EDT
Did you choose the Sis630 video card option when asked which video card you had
installed?
Comment 2 alan.vickers 2002-04-12 04:23:41 EDT
Yes, I did choose the highlighted SiS630 card
Comment 3 Michael Fulbright 2002-04-15 18:20:10 EDT
I will see if we have this hardware available for testing.
Comment 4 Michael Fulbright 2002-05-06 14:28:15 EDT
Closing due to inactivity. Please reopen if there is new information regarding
the issue report.
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.