Bug 63228 - Ctl+C to Ctl+V instantly crashes Galeon
Summary: Ctl+C to Ctl+V instantly crashes Galeon
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: galeon   
(Show other bugs)
Version: skipjack-beta2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
: 68402 (view as bug list)
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-04-11 14:56 UTC by Doug Stewart
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 18:49:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doug Stewart 2002-04-11 14:56:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
When copying a string or url from one tab in Galeon (via Ctl+C keyboard
shortcut) and pasting said string into form elements on another tab (via Ctl+V.
 This specifically occurs when I attempt to cut n' paste a url from the URL: bar
into the Body: field on my Yahoo! mail account.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ctl+C a URL from the url bar in Galeon
2. Switch to a tab with a form on it.
3. Ctl+V the url into a form element.
	

Actual Results:  Galeon (the GUI portion) crashed.  A background (zombie)
process appears to be left behind every once in a while (non-regular occurrence).

Expected Results:  The bloody URL should have been pasted into my form element.

Additional info:

Comment 1 petrosyan 2002-04-12 22:07:42 UTC
i could reproduce your bug easily on my PIII laptop even after all the recent
up2dates installed upon skipjack beta-2.


Comment 2 Christopher Blizzard 2002-04-15 15:10:45 UTC
I can't reproduce this.  It's working just fine here.  Is there a site that is
publically accessable that I can reproduce this?

Comment 3 Doug Stewart 2002-04-15 15:40:52 UTC
I could give you a login to my home box.  It's on a Comcast cable modem.  You
could try running Galeon remotely.

I just tried it and achieved the same results as when I run it locally.

Comment 4 Doug Stewart 2002-04-15 15:42:29 UTC
Another note:
The easiest way I've found to do this is by attempting to paste a URL from
another tab into the body of a message on my Yahoo! mail account.  Perhaps that
will help in diagnosing the issue.

Comment 5 Doug Stewart 2002-04-15 15:45:05 UTC
Another update:
Running it as root actually gives an error message on the terminal (as opposed
to running it as a user, which gives no error message). Namely: 

"Gdk-ERROR **: file gdkselection.c: line 246 (gdk_string_to_compound_text):
assertion failed: (property.encoding == gdk_atom_intern ("COMPOUND_TEXT", FALSE)
&& property.format == 8)
aborting...
Aborted


Comment 6 Preston Brown 2002-07-23 18:49:43 UTC
*** Bug 68402 has been marked as a duplicate of this bug. ***

Comment 7 Christopher Blizzard 2002-08-29 22:18:19 UTC
Working in rawhide.


Note You need to log in before you can comment on or make changes to this bug.