Bug 632371 - [6.1 FEAT] Rebase OpenMPI to 1.4.3 (or later)
[6.1 FEAT] Rebase OpenMPI to 1.4.3 (or later)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openmpi (Show other bugs)
6.1
All All
high Severity high
: beta
: 6.1
Assigned To: Jay Fenlason
Red Hat Kernel QE team
: FutureFeature, OtherQA, Rebase
: 636627 (view as bug list)
Depends On:
Blocks: 662543 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-09 15:01 EDT by IBM Bug Proxy
Modified: 2014-08-31 19:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The OpenMPI packages have been upgraded to upstream version 1.4.3, which provides a number of bug fixes and enhancements
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 66866 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-09 15:01:28 EDT
1. Feature Overview:
Feature Id: [66866]
a. Name of Feature: [6.1 FEAT] Rebase OpenMPI to 1.4.3 (or later)
b. Feature Description
Pick up the latest in the OpenMPI 1.4.x series (at least 1.4.3)

2. Feature Details:
Sponsor: LTC Networking
Architectures:  ppc64, x86_64, 

Arch Specificity: both
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Feature from Upstream
d. Upstream Acceptance: Field does not exist
Sponsor Priority P2
f. Severity: high
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target:---

3. Business Case
The latest releases in the Open MPI 1.4.x stable series contains bug fixes, some of which are
specific to the Power architecture.  This includes such things as fixes for using processor affinity
on Power platforms with different SMT modes.  Getting the latest in the 1.4.x series will ensure
that our HPC customers using Open MPI will have improved performance as well as a more stable release.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael L. Hohnbaum, hbaum@us.ibm.com

Technical contact(s):
WALTER B. BENTON, brad.benton@us.ibm.com
Comment 3 Jay Fenlason 2010-09-13 16:49:09 EDT
Ack as long as 1.4.3 comes out before 6.1 package freeze.
Comment 4 IBM Bug Proxy 2010-10-04 11:32:21 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:36 EDT-------
Code Upstream Status: Accepted
Comment 5 IBM Bug Proxy 2010-11-04 16:41:04 EDT
------- Comment From brad.benton@us.ibm.com 2010-11-04 16:39 EDT-------
Open MPI 1.4.3 was released on 10/5/2010.  It can be downloaded from:
http://www.open-mpi.org/software/ompi/v1.4
Comment 6 John Jarvis 2010-12-16 13:03:51 EST
*** Bug 636627 has been marked as a duplicate of this bug. ***
Comment 7 Suzanne Yeghiayan 2011-01-05 15:07:02 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time.  This request has been
proposed for the next release of Red Hat Enterprise Linux.
If you would like it considered as an exception in the 
current release, please ask your support representative.
Comment 8 IBM Bug Proxy 2011-01-10 22:31:31 EST
------- Comment From brad.benton@us.ibm.com 2011-01-10 22:27 EDT-------
Here is a list of fixes that are in the Open MPI 1.4.3 release which IBM views as crucial for Power systems:

- Fixed problems in processor affinity support, including when
there are "holes" in the processor namespace (e.g., offline
processors).
[IBM COMMENT] This is especially crucial for IBM & the Power architecture so that the user has control over process affinity, particularly on P7 with its multiple SMT modes.

- 1.4.3 has the re-licensed LoadLeveler code from IBM such that it is now compliant with the BSD license.
[IBM COMMENT]  Resolution of this licensing issue was required by Red Hat

- Numerous fixes in support of MPI_THREAD_MULTIPLE
[IBM COMMENT]  We currently have a customer for which this is crucial

- Fixed an incorrect branch in some ppc32 assembly code.
[IBM COMMENT] This error was discovered in the field, so already has an applicable customer use case & requirement for fixing

- Numerous bug fixes for both stability and correctness
[IBM COMMENT] While not an IBM-only requirement, these improvements benefit the community as a whole

Question:  RHEL6.0 includes Open MPI 1.4.1.  What is currently in plan for 6.1?  1.4.1 or 1.4.2?
Comment 9 John Jarvis 2011-01-13 10:41:23 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 11 Hushan Jia 2011-03-18 02:22:27 EDT
@IBM,
Could you test this request with rhel6.1 beta bits openmpi-1.4.3-1.1.el6? and post your test feedback here.

Thanks.
Comment 12 Eva Kopalova 2011-04-04 12:44:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The OpenMPI packages have been upgraded to upstream version 1.4.3, which provides a number of bug fixes and enhancements
Comment 13 Chris Ward 2011-04-06 07:11:56 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 14 IBM Bug Proxy 2011-04-21 16:00:51 EDT
------- Comment From brad.benton@us.ibm.com 2011-04-21 15:52 EDT-------
I tested openmpi-1.4.3-1.1.el6 from 6.1beta on both x86_64 and ppc64 platforms.  Shared memory, TCP/IP, and InfiniBand were the tested transports.  All tests (NPB) ran to completion and the computational results were successfully verified.  So, this looks good.
Comment 15 John Jarvis 2011-04-21 16:06:54 EDT
Marking partner Verified per IBM feedback.
Comment 16 errata-xmlrpc 2011-05-19 09:11:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0590.html

Note You need to log in before you can comment on or make changes to this bug.